Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

dsabnani's profile - activity

2017-02-26 23:35:14 -0700 received badge  Taxonomist
2016-08-31 01:44:32 -0700 received badge  Famous Question (source)
2016-03-10 12:48:01 -0700 received badge  Famous Question (source)
2016-02-24 01:28:32 -0700 received badge  Notable Question (source)
2016-01-04 04:17:24 -0700 received badge  Notable Question (source)
2016-01-03 21:57:38 -0700 received badge  Popular Question (source)
2015-12-30 08:02:18 -0700 received badge  Popular Question (source)
2015-12-22 09:32:05 -0700 answered a question Two flows (match: input interface, output: punt to controller) installed on its own, on deleting a flow from opendaylight controller.

Hello,

ODL version is: distribution-karaf-0.3.1-Lithium-SR1

Features installed: opendaylight-user@root>feature:install odl-restconf opendaylight-user@root>feature:install odl-dlux-all opendaylight-user@root>feature:install odl-l2switch-switch opendaylight-user@root>feature:install odl-mdsal-apidocs opendaylight-user@root>feature:install odl-openflowplugin-flow-services-ui opendaylight-user@root>

Adding/Deleting the flows using the Yang UI.

2015-12-22 00:20:38 -0700 commented answer enqueue action - flow with set-queue action is not installed in the switch.

Hi Harsha, It still did not work for me. Here is what I did - http://pastebin.com/UT3DAygf

2015-12-22 00:07:13 -0700 asked a question Two flows (match: input interface, output: punt to controller) installed on its own, on deleting a flow from opendaylight controller.

I am using Open-daylight controller to install flows on Cisco switches.

On deleting an installed flow, two more flows get installed (match - input interface, output - punt to controller). I have two Open-flow interfaces configured on the switch currently. Is this an expected behavior ? What do I do to avoid this ?

Installing 1st flow - 3650stack#sh openflow switch 1 flows controller brief openflow-3650stack-5821 Logical Switch Id: 1 Total flows: 3 Flow: 1 Match: udp,nw_src=9.9.9.9 Actions: output:5098 Priority: 32768, Table: 0, Cookie: 0x0, Duration: 3.154s, Packets: 0, Bytes: 0 Flow: 2 Match: dl_type=0x88cc Actions: CONTROLLER:65535 Priority: 100, Table: 0, Cookie: 0x2b00000000000001, Duration: 3.154s, Packets: 0, Bytes: 0 Flow: 3 Match: Actions: drop Priority: 0, Table: 0, Cookie: 0x2b00000000000000, Duration: 3.211s, Packets: 0, Bytes: 0 After deleting the flow#1 from the switch, two more flows get installed on its own. 3650stack#sh openflow switch 1 flows controller brief openflow-3650stack-5821 Logical Switch Id: 1 Total flows: 4 Flow: 1 Match: dl_type=0x88cc Actions: CONTROLLER:65535 Priority: 100, Table: 0, Cookie: 0x2b00000000000001, Duration: 15.983s, Packets: 0, Bytes: 0 Flow: 2 Match: in_port=5098 Actions: output:5097,CONTROLLER:65535 Priority: 2, Table: 0, Cookie: 0x2b00000000000000, Duration: 12.117s, Packets: 0, Bytes: 0 Flow: 3 Match: in_port=5097 Actions: output:5098,CONTROLLER:65535 Priority: 2, Table: 0, Cookie: 0x2b00000000000001, Duration: 12.117s, Packets: 0, Bytes: 0 Flow: 4 Match: Actions: drop Priority: 0, Table: 0, Cookie: 0x2b00000000000000, Duration: 16.04s, Packets: 0, Bytes: 0 3650stack#

This is impacting my automation work since any flow that i install matches one of the two flows installed and my test case fails. Please help.

Thanks.

2015-12-01 22:24:03 -0700 asked a question enqueue action - flow with set-queue action is not installed in the switch.

Hello Everyone,

I have the below flow which I am trying to install in a Cisco Switch. It uses the set-queue action followed by output action. It is not installed on the switch.

http://10.106.253.118:8181/restconf/c... { "flow": [ { "id": "2", "match": { "ethernet-match": { "ethernet-type": { "type": "0x0800" } }, "ip-match": { "ip-proto": "ipv4" } }, "instructions": { "instruction": [ { "order": "0", "apply-actions": { "action": [ { "set-queue-action": { "queue": "2000", "queue-id": "1" }, "order": "0" }, { "output-action": { "output-node-connector": "openflow:292517539810831:5097" }, "order": "1" } ] } } ] }, "table_id": "0" } ] }

Am I missing something ?

2015-10-08 02:47:02 -0700 received badge  Editor (source)
2015-10-08 02:29:18 -0700 asked a question Lithium: Exception on executing ./bin/karaf in redhat.

I installed Opendaylight Lithium on Redhat. i receive the following errors/exceptions every time I start the karaf process (./bin/karaf)

Listening on port 12001 bound on address 0.0.0.0/0.0.0.0 opendaylight-user@root>Exception in thread "Thread-69" java.net.BindException: Address already in use

I came across this question, but I still see the issue - https://ask.opendaylight.org/question/1535/address-already-in-use-during-karaf-run/

Also I am not able to connect using - http://<ip>:8181:/index.html</ip> from my browser. HTTP ERROR: 404 Problem accessing /index.html. Reason: Not Found Powered by Jetty://

I am using the following version of Java. [root@deepti-redhat7 distribution-karaf-0.3.1-Lithium-SR1]# java -version java version "1.7.051" OpenJDK Runtime Environment (rhel-2.4.5.5.el7-x8664 u51-b31) OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode) [root@deepti-redhat7 distribution-karaf-0.3.1-Lithium-SR1]#

--- Logs --- [root@deepti-redhat7 distribution-karaf-0.3.1-Lithium-SR1]# ./bin/karaf

________                       ________                .__  .__       .__     __       
\_____  \ ______   ____   ____ \______ \ _____  ___.__.|  | |__| ____ |  |___/  |_     
 /   |   \\____ \_/ __ \ /    \ |    |  \\__  \<   |  ||  | |  |/ ___\|  |  \   __\    
/    |    \  |_> >  ___/|   |  \|    `   \/ __ \\___  ||  |_|  / /_/  >   Y  \  |      
\_______  /   __/ \___  >___|  /_______  (____  / ____||____/__\___  /|___|  /__|      
        \/|__|        \/     \/        \/     \/\/            /_____/      \/

Hit '<tab>' for a list of available commands and '[cmd] --help' for help on a specific command. Hit '<ctrl-d>' or type 'system:shutdown' or 'logout' to shutdown OpenDaylight.</ctrl-d></tab>

opendaylight-user@root> opendaylight-user@root>GossipRouter started at Thu Oct 08 14:11:17 IST 2015 Listening on port 12001 bound on address 0.0.0.0/0.0.0.0 Backlog is 1000, linger timeout is 2000, and read timeout is 0

opendaylight-user@root>Exception in thread "Thread-69" java.net.BindException: Address already in use at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Net.java:444) at sun.nio.ch.Net.bind(Net.java:436) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74) at io.netty.channel.socket.nio.NioServerSocketChannel.doBind(NioServerSocketChannel.java:125) at io.netty.channel.AbstractChannel$AbstractUnsafe.bind(AbstractChannel.java:485) at io.netty.channel.DefaultChannelPipeline$HeadContext.bind(DefaultChannelPipeline.java:1081) at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:502) at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:487) at io.netty.channel.ChannelDuplexHandler.bind(ChannelDuplexHandler.java:38) at io.netty.handler.logging.LoggingHandler.bind(LoggingHandler.java:240) at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:502) at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:487) at io.netty.channel.DefaultChannelPipeline.bind(DefaultChannelPipeline.java:904) at io.netty.channel.AbstractChannel.bind(AbstractChannel.java:198) at io.netty.bootstrap.AbstractBootstrap$2.run(AbstractBootstrap.java:348) at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:357) at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:357) at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:111) at io.netty.util.concurrent.DefaultThreadFactory$DefaultRunnableDecorator.run(DefaultThreadFactory.java:137) at java.lang.Thread.run(Thread.java:744)

opendaylight-user@root>

The following ports are being used by java and no ... (more)