Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Sona's profile - activity

2015-09-10 18:20:21 -0700 received badge  Famous Question (source)
2015-07-24 03:39:00 -0700 received badge  Notable Question (source)
2015-07-06 16:07:40 -0700 received badge  Notable Question (source)
2015-07-06 16:07:40 -0700 received badge  Famous Question (source)
2015-07-03 04:06:53 -0700 commented question how to integrate opendaylight helium controller with l2switch

Basically i want to change stats mangers code for which i need that controller to be integrated with l2switch to ping the hosts so that i can see the stats changes.

2015-07-03 00:10:48 -0700 received badge  Popular Question (source)
2015-07-02 03:19:46 -0700 commented answer how to integrate opendaylight helium controller with l2switch

working with java 1.7 only..any other workaround???????

2015-06-30 23:41:02 -0700 asked a question how to integrate opendaylight helium controller with l2switch

Hi,

I have downloaded the l2switch with controller and openflow plugin, tried to installed all the features on karaf console of l2switch but at that time hosts are not getting pinged.

Also, while trying to install feature on karaf console the below error is getting occurred:

opendaylight-user@root>feature:install odl-l2switch-all Error executing command: Could not start bundle mvn:org.opendaylight.yangtools/concepts/0.7.1-SNAPSHOT in feature(s) odl-yangtools-common-0.7.1-SNAPSHOT: The bundle "org.opendaylight.yangtools.concepts_0.7.1.SNAPSHOT [71]" could not be resolved. Reason: Missing Constraint: Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))"

Now I have changed to other alternative where first i have compiled the l2switch code and tried to ping the hosts which is working now. As of now I want to make some changes in the stats manager which is present in the controller in Helium release. So, anyone please help in and let me know that how i can integrate the controller with l2switch by taking them individually from the github.

Please kindly help!

2015-06-30 09:39:51 -0700 received badge  Popular Question (source)
2015-06-30 02:59:45 -0700 commented answer hosts not pinging(l2switch issue maybe)

Previously java version used was 1.8 but now I am using the Java 1.7 itself though it is not working with this version also.

2015-06-30 00:58:01 -0700 received badge  Editor (source)
2015-06-30 00:56:20 -0700 commented answer hosts not pinging(l2switch issue maybe)

Hi hjdeore, I am trying to install these features on karaf console but below error occurred: opendaylight-user@root>feature:install odl-l2switch-all Error executing command: Could not start bundle mvn:org.opendaylight.yangtools/concepts/0.7.1-SNAPSHOT in feature(s) odl-yangtools-common-0.7.1-SNAPSHOT: The bundle "org.opendaylight.yangtools.concepts_0.7.1.SNAPSHOT [71]" could not be resolved. Reason: Missing Constraint: Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))" I have tried to find the solution to the error but could not make it..so can you please comment or help what should be done in this case? Thanks !

2015-06-29 05:08:27 -0700 asked a question hosts not pinging(l2switch issue maybe)

I have downloaded stable lithium's code from git-hub for - controller, l2switch and openflow plugin. After compiling all the three modules with maven , I am creating topology using mininet specifying remote controller by giving the below command: sudo mn --topo single,3 --mac --switch ovsk,protocols=OpenFlow13 --controller remote

After that I am trying to ping the hosts with the opendaylight controller ( ./karaf in assembly/bin).

Also, while trying to install feature on karaf console the below error is getting occurred:

opendaylight-user@root>feature:install odl-l2switch-all Error executing command: Could not start bundle mvn:org.opendaylight.yangtools/concepts/0.7.1-SNAPSHOT in feature(s) odl-yangtools-common-0.7.1-SNAPSHOT: The bundle "org.opendaylight.yangtools.concepts_0.7.1.SNAPSHOT [71]" could not be resolved. Reason: Missing Constraint: Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))"

Kindly help!!!!!!