Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Zetheroth's profile - activity

2018-01-15 04:37:05 -0700 received badge  Popular Question (source)
2018-01-15 04:37:05 -0700 received badge  Notable Question (source)
2018-01-15 04:37:05 -0700 received badge  Famous Question (source)
2017-05-30 11:57:56 -0700 commented answer Flow pushed using config REST API is not reflected via operational REST API

The mininet command that I use is: "sudo mn --topo linear,3 --mac --controller=remote,ip=192.168.56.103 --switch ovs,protocols=OpenFlow13"

2017-05-30 11:57:31 -0700 commented answer Flow pushed using config REST API is not reflected via operational REST API

I used the same REST call that you posted, but I received an error saying that the relevant data model content does not exist. This error has persisted with every config Rest api call, as well as most of the operational Rest api calls. I am using mininet with an ODL remote controller, 3 swtch&3host

2017-05-30 10:52:34 -0700 received badge  Editor (source)
2017-05-30 10:49:51 -0700 asked a question Data Missing Error, data model does not exist

Whenever I issue any config and most operational commands from the OpendayLight RestConf API Documentation or the Yang UI I always get this error:

{
     "errors" : {
          "error": [
              {
                   "error-type": "application",
                   "error-tag": "data-missing",
                   "error-message": "Request could not be completed because the relevant data model content does not exist"
             }
          ]
     }
 }

The Response code is 404.

I am running Opendaylight on a vm and using mininet on a separate vm to connect to ODL as a remote controller. With mininet, I am creating a network of three switches connected to each other, each with its own host. The command that I use to create my network in mininet is: "sudo mn --topo linear,3 --mac --controller=remote,ip=192.168.56.103 --switch ovs,protocols=OpenFlow13".

The only RestConf operations I have been able to use are network-topology (/operational/network-topology:network-topology) and nodes (/operational/opendaylight-inventory:nodes).

I saw that a similar question was asked: about having a request error but my problem persists.

2017-05-30 07:58:14 -0700 commented answer Request could not be completed because the relevant data model content does not exist

If I am using Mininet with OpenDaylight how would I do this? Or what documentation should I read for this? Because, I'm having this problem with all config and most operational commands in the RestConf.