Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

creasyboy2002's profile - activity

2016-04-22 12:24:56 -0700 received badge  Famous Question (source)
2016-04-14 02:42:55 -0700 received badge  Notable Question (source)
2016-04-11 08:23:20 -0700 received badge  Popular Question (source)
2016-04-10 18:07:38 -0700 received badge  Popular Question (source)
2016-04-10 18:07:38 -0700 received badge  Notable Question (source)
2016-04-10 18:07:38 -0700 received badge  Famous Question (source)
2016-04-08 00:17:28 -0700 asked a question compile controller error:java.util.zip.ZipException: error in opening zip file

how to solve it? when i compile controller of berryllium-sr1,some error happen like this:

in org.opendaylight.controller.sample.toaster.it.ToasterTest testToaster(org.opendaylight.controller.sample.toaster.it.ToasterTest) Time elapsed: 1.72 sec <<< ERROR! java.util.zip.ZipException: error in opening zip file at java.util.zip.ZipFile.open(Native Method) at java.util.zip.ZipFile.<init>(ZipFile.java:219) at java.util.zip.ZipFile.<init>(ZipFile.java:149) at java.util.zip.ZipFile.<init>(ZipFile.java:163) at org.eclipse.core.runtime.internal.adaptor.PluginConverterImpl.findPluginManifest(PluginConverterImpl.java:178) at org.eclipse.core.runtime.internal.adaptor.PluginConverterImpl.fillPluginInfo(PluginConverterImpl.java:109) at org.eclipse.core.runtime.internal.adaptor.PluginConverterImpl.convertManifest(PluginConverterImpl.java:714) at org.eclipse.core.runtime.internal.adaptor.EclipseStorageHook.generateManifest(EclipseStorageHook.java:448) at org.eclipse.core.runtime.internal.adaptor.EclipseStorageHook.getGeneratedManifest0(EclipseStorageHook.java:428)

2016-04-04 20:05:43 -0700 asked a question No karaf base dir found.error while compile odlparent.Help me please.

I use mvn clean install to compile odlparent of version berrllium-sr1. And I get errors below. How to solve it?Thanks. java.lang.IllegalStateException: No karaf base dir found in extracted distribution. at org.ops4j.pax.exam.karaf.container.internal.KarafTestContainer.searchKarafBase(KarafTestContainer.java:509) at org.ops4j.pax.exam.karaf.container.internal.KarafTestContainer.start(KarafTestContainer.java:152) at org.ops4j.pax.exam.spi.reactors.AllConfinedStagedReactor.invoke(AllConfinedStagedReactor.java:79) at org.ops4j.pax.exam.junit.impl.ProbeRunner$2.evaluate(ProbeRunner.java:267) at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:271) at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:70) at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50) at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238) at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:63) at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:236) at org.junit.runners.ParentRunner.access$000(ParentRunner.java:53) at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:229) at org.junit.runners.ParentRunner.run(ParentRunner.java:309) at org.ops4j.pax.exam.junit.impl.ProbeRunner.run(ProbeRunner.java:98) at org.ops4j.pax.exam.junit.PaxExam.run(PaxExam.java:93) at org.opendaylight.odlparent.featuretest.PerFeatureRunner.run(PerFeatureRunner.java:71) at org.opendaylight.odlparent.featuretest.PerRepoTestRunner.runChild(PerRepoTestRunner.java:122) at org.opendaylight.odlparent.featuretest.PerRepoTestRunner.runChild(PerRepoTestRunner.java:29) at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238) at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:63) at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:236) at org.junit.runners.ParentRunner.access$000(ParentRunner.java:53) at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:229) at org.junit.runners.ParentRunner.run(ParentRunner.java:309) at org.apache.maven.surefire.junit4.JUnit4Provider.execute(JUnit4Provider.java:283) at org.apache.maven.surefire.junit4.JUnit4Provider.executeWithRerun(JUnit4Provider.java:173) at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:153) at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:128) at org.apache.maven.surefire.booter.ForkedBooter.invokeProviderInSameClassLoader(ForkedBooter.java:203) at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:155) at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:103)

2016-04-01 00:46:18 -0700 commented answer question about l2switch of beryllium,help me please!!!!

thank you ,I solve the problem. the reason is that i did not use the tag version. Thank you very much

2016-04-01 00:44:48 -0700 received badge  Enthusiast
2016-03-31 02:08:47 -0700 received badge  Famous Question (source)
2016-03-31 00:20:23 -0700 commented answer question about l2switch of beryllium,help me please!!!!

thank for you help. I used to think it is the version problem too.I tried "git pull" then,but it did not work. Isn't Beryllium a stable released version? I did not find the Beryllium-SR1's souce code. How to use that code?

2016-03-31 00:19:48 -0700 answered a question question about l2switch of beryllium,help me please!!!!

thank for you help. I used to think it is the version problem too.I tried "git pull" then,but it did not work. Isn't Beryllium a stable released version? I did not find the Beryllium-SR1's souce code. How to use that code? using git branch -a ,I just find these branches. master pre-boron * stable/beryllium stable/lithium remotes/origin/HEAD -> origin/master remotes/origin/master remotes/origin/pre-boron remotes/origin/stable/beryllium remotes/origin/stable/helium remotes/origin/stable/lithium

2016-03-28 07:31:19 -0700 received badge  Notable Question (source)
2016-03-22 04:24:05 -0700 received badge  Popular Question (source)
2016-03-21 19:42:19 -0700 received badge  Editor (source)
2016-03-20 18:37:13 -0700 asked a question question about l2switch of beryllium,help me please!!!!

why version of l2switch of beryllium is 0.3.1SNAP-SHOT,but Integration of beryllium require l2switch of 0.3.0 SNAP-SHOT? I met this problem while I install from source code.

I want to make some change to the l2switch source code,but the change didn't take affect when I integrate it with integration
project. The beryllium integration project depends l2switch of version 0.3.0SNAP-SHOT,but the version of beryllium l2switch is 0.3.1 SNAP-SHOT.

Can any master tell me how to build beryllium from source code?