Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Revision history [back]

click to hide/show revision 1
initial version

Issue with yang-ext:mount

When I try the below two commands, in both the cases, I'm getting errors as below

curl -v http://localhost:8080/restconf/config/opendaylight-inventory:nodes/node/libnetconfd/yang-ext:mount/ curl -v http://localhost:8080/restconf/operational/opendaylight-inventory:nodes/node/libnetconfd/yang-ext:mount/

ERRORS:

[root@bti-ma-sdn opendaylight]# curl -v http://localhost:8080/restconf/config/opendaylight-inventory:nodes/node/Atlas7800Adi 1/yang-ext:mount/ * About to connect() to localhost port 8080 (#0) * Trying ::1... connected * Connected to localhost (::1) port 8080 (#0)

GET /restconf/config/opendaylight-inventory:nodes/node/Atlas7800Adi1/yang-ext:mount/ HTTP/1.1 User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.14.0.0 zlib/1.2.3 libidn/1.18 libssh2/1.4.2 Host: localhost:8080 Accept: /

< HTTP/1.1 400 Bad Request < Server: Apache-Coyote/1.1 < Cache-Control: private < Expires: Wed, 31 Dec 1969 19:00:00 EST < Content-Type: text/plain < Transfer-Encoding: chunked < Date: Mon, 19 May 2014 18:39:57 GMT < Connection: close < * Closing connection #0

Can someone point me to where Im going wrong?

Issue with yang-ext:mount

When I try the below two commands, in both the cases, I'm getting errors as below

curl -v http://localhost:8080/restconf/config/opendaylight-inventory:nodes/node/libnetconfd/yang-ext:mount/ curl -v http://localhost:8080/restconf/operational/opendaylight-inventory:nodes/node/libnetconfd/yang-ext:mount/

ERRORS:

[root@bti-ma-sdn opendaylight]# curl -v http://localhost:8080/restconf/config/opendaylight-inventory:nodes/node/Atlas7800Adi 1/yang-ext:mount/ * About to connect() to localhost port 8080 (#0) * Trying ::1... connected * Connected to localhost (::1) port 8080 (#0)

GET /restconf/config/opendaylight-inventory:nodes/node/Atlas7800Adi1/yang-ext:mount/ HTTP/1.1 User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.14.0.0 zlib/1.2.3 libidn/1.18 libssh2/1.4.2 Host: localhost:8080 Accept: /

< HTTP/1.1 400 Bad Request < Server: Apache-Coyote/1.1 < Cache-Control: private < Expires: Wed, 31 Dec 1969 19:00:00 EST < Content-Type: text/plain < Transfer-Encoding: chunked < Date: Mon, 19 May 2014 18:39:57 GMT < Connection: close < * Closing connection #0

Can someone point me to where Im going wrong?