Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Revision history [back]

click to hide/show revision 1
initial version

Missing Constraint: Import-Package: com.thetransactioncompany.jsonrpc2; version="0.0.0"

Hi Guys,

I am getting subjected error while installing one feature in karaf, i have included dependency in xml file also

<dependency> <groupid>com.thetransactioncompany</groupid> <artifactid>jsonrpc2-base</artifactid> <version>1.38</version> </dependency>

though i am getting error. Please suggest.

Regards, Harish

Missing Constraint: Package conflict: Import-Package: com.thetransactioncompany.jsonrpc2; version="0.0.0"error in karaf

Hi Guys,

I am getting subjected error while installing one feature in karaf, i have included dependency in xml file alsokaraf,

<dependency> <groupid>com.thetransactioncompany</groupid> <artifactid>jsonrpc2-base</artifactid> <version>1.38</version> </dependency>Error executing command: Can't install feature odl-l2switch-mynetworktopology/0.0.0: Could not start bundle mvn:org.opendaylight.l2switch.mynetworktopology/mynetworktopology-impl/0.2.0-Lithium in feature(s) odl-l2switch-mynetworktopology-0.2.0-Lithium: The bundle "org.opendaylight.l2switch.mynetworktopology.impl_0.2.0.Lithium [220]" could not be resolved. Reason: Package uses conflict: Import-Package: org.opendaylight.controller.config.yang.md.sal.binding; version="[1.2.0,2.0.0)", Package uses conflict: Import-Package: org.opendaylight.controller.md.sal.binding.api; version="[1.2.0,2.0.0)", Package uses conflict: Import-Package: org.opendaylight.controller.md.sal.common.api.data; version="[1.2.0,2.0.0)", Package uses conflict: Import-Package: org.opendaylight.yang.gen.v1.urn.intel.params.xml.ns.yang.mynetwork.topology.rev150525; version="[0.2.0,1.0.0)", Package uses conflict: Import-Package: org.opendaylight.yang.gen.v1.urn.intel.params.xml.ns.yang.mynetwork.topology.rev150525.mynetwork.topology.topology; version="[0.2.0,1.0.0)", Package uses conflict: Import-Package: org.opendaylight.yang.gen.v1.urn.tbd.params.xml.ns.yang.network.topology.rev131021; version="[2013.10.0,2014.0.0)", Package uses conflict: Import-Package: org.opendaylight.yangtools.yang.binding; version="[0.7.0,1.0.0)", Package uses conflict: Import-Package: org.opendaylight.yangtools.yang.common; version="[0.7.0,1.0.0)"

though i am getting error. Please suggest.

Regards, Harish