Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Revision history [back]

click to hide/show revision 1
initial version

Unable to ping instances on running OVS set-controller to Opendaylight

I create two Ubuntu instance (VM1 and VM2) using VirtualBox and then I installed and configured

1) OVS + ODL in VM1 instance and
2) OVS in VM2 instance

I created a bridge br0 in both the instances and binded that to eth0 interface. On assigning IP address, I was able to ping both the instances.

Now, I ran "./" startup script of Opendaylight and executed the below command in VM1

  set ovs-vsctl set-controller br0 tcp:<ip-address-of-ODL>:6633

In ODL web page I was able to see the br0 of VM1 instance as switch; then I ran the above command in VM2 instance too; Now on refreshing the ODL web page, I see VM2 instance as host connected to switch (br0) of OVS in VM1. Is this right behavior? I expected, ODL to show VM2 OVS also as switch as displayed for VM1.

Now coming to the actual problem, I was not able to ping VM1 and VM2 instances; I ran ovs-ofctl snoop command to see the packets that were coming

  ovs-ofctl snoop br0

and I could see the ARP request packet with scr of VM1 and dst mac of ff:ff:ff:... and I was able to see the ARP handler of OSGI is also ACTIVE. then why ARP couldn't be handled by ODL?

Is I am missing anything to configure? Please guide me on this. Thanks