Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Revision history [back]

click to hide/show revision 1
initial version

error while deploying jar in karaf

I have done few changes in snmp4sdn plugin and copied the jar file to "integration/distribution/extra/karaf/target/assembly/deploy" folder. After running the karaf, when I tried to start my bundle like "bunble:start id" i got the following error. Error executing command on bundles:

Unable to execute command on bundle 312: The bundle "org.opendaylight.snmp4sdn_0.2.0.SNAPSHOT [312]" could not be resolved. Reason: Missing Constraint: Import-Package: org.opendaylight.yang.gen.v1.urn.opendaylight.snmp4sdn.md.vlan.rev140815; version="[0.2.0,1.0.0)"

Can anyoen explain me why I am getting this and what is the solution for it?

error while deploying jar in karaf

I have done few changes in snmp4sdn plugin and copied the jar file to "integration/distribution/extra/karaf/target/assembly/deploy" folder. After running the karaf, when I tried to start my bundle like "bunble:start id" i got the following error. Error executing command on bundles:

Unable to execute command on bundle bundle 312: The bundle "org.opendaylight.snmp4sdn_0.2.0.SNAPSHOT bundle "org.opendaylight.snmp4sdn_0.2.0.SNAPSHOT [312]" could not be resolved. Reason: Reason: Missing Constraint: Import-Package: org.opendaylight.yang.gen.v1.urn.opendaylight.snmp4sdn.md.vlan.rev140815; Import-Package: org.opendaylight.yang.gen.v1.urn.opendaylight.snmp4sdn.md.vlan.rev140815; version="[0.2.0,1.0.0)"

Can anyoen explain me why I am getting this and what is the solution for it?