Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

Revision history [back]

click to hide/show revision 1
initial version

Unable to map tunnel-ipv4-source to tun_src while writing flow onto OVS

Hi All,

We are trying to write a flow on OVS from ODL with the body shown below. The flow is added successfully but the field "tunnel-ipv4-source" got mapped to "nwsrc" in OVS instead of "tunsrc"

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<flow xmlns="urn:opendaylight:flow:inventory">
<hard-timeout>0</hard-timeout>
<idle-timeout>0</idle-timeout>
<priority>150</priority>
<flow-name>flow1</flow-name>
<match>
<ethernet-match>
<ethernet-type>
<type>2048</type>
</ethernet-type>
</ethernet-match>
<tunnel-ipv4-source>10.2.1.1/32</tunnel-ipv4-source>
<tunnel>
<tunnel-id>5555</tunnel-id> 
</tunnel> 
</match>
<id>1</id>
<table_id>0</table_id>
<instructions>
<instruction>
<order>0</order>
<apply-actions>
<action>
<output-action>
<output-node-connector>1</output-node-connector>
</output-action>
<order>0</order>
</action>
</apply-actions>
</instruction>
</instructions>
</flow>

Response from OVS dump-flows for the above flow is shown below :

cookie=0x0, duration=3.237s, table=0, n_packets=0, n_bytes=0, idle_age=3, priority=150, ip,tun_id=0x15b3,nw_src=10.2.1.1 actions=output:1

Question : Why tunsrc does not appear on OVS flow , instead it gets mapped to nwsrc? Is there any other ODL parameter to which it should be mapped or are we missing any additional parameter in XML to get the mapping correct/intended.

Whereas when we add flow using ovs-ofctl add flows, we are able to see tun_src getting correctly mapped.

cookie=0x0, duration=3.237s, table=0, n_packets=0, n_bytes=0, idle_age=3, priority=150, tun_id=0x15b3, tun_src=10.2.1.1** actions=output:1

Please suggest.