Ask Your Question
0

couldn't find mandatory library org.eclipse.xtext.xbase.lib' 2.7.0?

asked 2014-10-30 05:31:09 -0700

jayakeerthi gravatar image

updated 2014-10-30 05:36:34 -0700

1)hydrogen/stable controller code is downloaded from github and builded from the CLI(mvn clean install) 2)imported to eclipse got error on yang-test-tool then i ran opendaylight.assemblit.lunch in eclipse and got this problem. 3)i tried updating the maven project but it didn't reslove the problem ERROR on console Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.5.1:compile (default-compile) on project sal: Fatal error compiling: tools.jar not found: C:\Program Files\Java\jre7..\lib\tools.jar -> [Help 1]

ERROR I GOT on FAILURE TAB Couldn't find the mandatory library 'org.eclipse.xtext.xbase.lib' 2.7.0 or higher on the project's classpath. FlowProgrammerAdapter.xtend /sal-compatibility/src/main/java/org/opendaylight/controller/sal/compatibility line: 8 /sal-compatibility/src/main/java/org/opendaylight/controller/sal/compatibility/FlowProgrammerAdapter.xtend Xtend Problem

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-07 12:30:28 -0700

strong text try change JAVA_HOME from jre to jdk

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2014-10-30 05:31:09 -0700

Seen: 228 times

Last updated: Nov 07 '14