Ask Your Question
1

Running karaf

asked 2014-10-23 20:05:35 -0700

51102644mt114 gravatar image

hi.please help me solve this problem.

when i run "./karaf" file, it shows me

"Exception in thread "JMX Connector Thread [service:jmx:rmi://0.0.0.0:44444/jndi/rmi://0.0.0.0:1099/karaf-root]" java.lang.RuntimeException: Could not start JMX connector server"

thanks.

edit retag flag offensive close merge delete

Comments

Please edit your question to include information like the ODL version you're using.

dfarrell07 ( 2014-10-24 09:30:51 -0700 )edit

I 'm using Helium version

51102644mt11tn ( 2014-10-24 21:52:20 -0700 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2014-10-24 12:15:23 -0700

shague gravatar image

One user had a similar issue. Turned out they had firewall rules blocking the ports.

edit flag offensive delete publish link more

Comments

1

Actually, I turned off firewall, this issue still showed

51102644mt11tn ( 2014-10-24 21:54:40 -0700 )edit
0

answered 2014-11-01 02:35:12 -0700

It is due that no suitable value of MaxPermSize parameter of JVM was set. so in order to resolve this issue, please edit file setEnv.bat/setEnv.sh in ./bin direction to set initial value of this parameter. it is reasonable to set its value to 64M or 128M.

SET MAXPERMSIZE=64m.

after apply the modification, you restart helium via ./bin/karaf, it will be work.

edit flag offensive delete publish link more

Comments

In my `bin/setenv` there is already a high value: `export JAVA_MAX_PERM_MEM="512m"`. It does not work neither this way. I mean the firewall is already off.

skywalker ( 2014-11-12 05:40:33 -0700 )edit
0

answered 2015-01-07 14:53:23 -0700

vmdaylight gravatar image

updated 2015-01-07 14:57:33 -0700

RMI port number is defined in a configuration file, etc/org.apache.karaf.management.cfg. Here are steps to modify port number on Unix server for Helium release:

  • cd distributon-karaf-0.2.1-Helium-SR1.1
  • cd etc
  • vi org.apache.karaf.management.cfg
    (modify RMI port number)
edit flag offensive delete publish link more
0

answered 2015-01-07 21:35:02 -0700

faizan gravatar image

In /controller/karaf/opendaylight-karaf/target/assembly/etc/ Go to org.apache.karaf.management.cfg and change 0.0.0.0 to meaningfull IP like 127.0.0.1 :)

edit flag offensive delete publish link more

Comments

yes this works...thanks...I will update the path here for Lithium "distribution-karaf-0.3.1-Lithium-SR1/etc", edit the file "org.apache.karaf.management.cfg". change 0.0.0.0 to 127.0.0.1 anr run karaf again (./bin/karaf)

sanjibdas ( 2015-09-25 22:44:41 -0700 )edit

welcome :)

faizan ( 2015-09-26 10:37:45 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
2 followers

Stats

Asked: 2014-10-23 20:05:35 -0700

Seen: 1,596 times

Last updated: Jan 07 '15