Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode


Error executing command: No feature named 'transaction'

asked 2014-10-20 02:08:59 -0800

arlie gravatar image

updated 2014-10-20 02:12:22 -0800

I tried to install "odl-base-all" feature but the following error is displayed.

opendaylight-user@root>feature:install odl-base-all Error executing command: No feature named 'transaction' with version '0.0.0' available

The following are the commands performed so far 1) Download opendaylight helium (zip) 2) run karaf (./bin/karaf) 3) feature:install odl-base-all

Do I need to configure something? Is there a required component or dependency?

If I remove "transaction" feature as dependency for "odl-base-all", installation will be successful. /root/distribution-karaf-0.2.0-Helium/system/org/opendaylight/controller/features-base/1.4.2-Helium/features-base-1.4.2-Helium-features.xml 4 <feature description="OpenDaylight Controller" name="odl-base-all" version="1.4.2-Helium"> 5 <feature>http</feature> 6 </feature>

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2014-11-04 16:49:56 -0800

tbachman gravatar image

I heard that someone was able to work around this by building the controller locally.

edit flag offensive delete publish link more

answered 2014-12-02 23:48:43 -0800

Compile difference helium , I find normal one has more files at ../system/org/apache/karaf/features which name are enterprise/3.0.1/enterprise-3.0.1-features.xml and spring/3.0.1/spring-3.0.1-features.xml,while error one does not have.I think it is a reason to your problem.

edit flag offensive delete publish link more

answered 2014-12-19 12:27:43 -0800

mgkwill gravatar image

This is likely a proxy issue or some sort of corrupted local maven repository. Try the following steps.

Maven Settings

Check that maven is installed and your settings.xml file for maven at /usr/share/maven/conf/settings.xml is configured correctly (double check proxy settings, nexus repository settings etc). Edit etc files for karaf to point to shared maven config:

cd <karaf-distro>/etc

Edit org.ops4j.pax.url.mvn.cfg and add



Add proxy setting below only if you are using a proxy


Delete Local Maven Repository and Karaf Data contents

Remove the repository folder in your .m2 directory:

rm -rf ~/.m2/repository

Remove the data folder content:

rm -rf <karaf-distro>/data/*

Karaf uses maven to download dependencies at run-time, if there are conflicts in the maven repository or a proxy is blocking maven from downloading dependencies you will experience this issue.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2014-10-20 02:08:59 -0800

Seen: 1,682 times

Last updated: Dec 19 '14