Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

ODL openvswitch ovs connection problem

asked 2015-12-15 05:49:00 -0800

Rui gravatar image

Hi there,

I'm trying to configure a testbed with opendaylight lithium (odl) and openvswitch(ovs) but I'm having some problems. Can someone give me a hand? Until now I wasn't able to connect OVS to ODL and make ODL act as the network controller. This is the info I'm getting now related to the controller:

$ ovs-vsctl list controller

_uuid : 6ed37533-500f-47bc-8b79-249fc07af1b8

connection_mode : []

controllerburstlimit: []

controllerratelimit: []

enableasyncmessages: []

external_ids : {}

inactivity_probe : []

is_connected : false

local_gateway : []

local_ip : []

local_netmask : []

max_backoff : []

other_config : {}

role : other

status : {lasterror="No route to host", secsince_disconnect="8", state=CONNECTING}

target : "tcp:10.0.0.200:6633"

This is what I've accomplish until now:

ODL I'm able to connect mininet to ODL and confirm the topology on DLUX. So, from the controller side everything seems to be going well.

OVS - Machine running CentOS 7 with several network interfaces.

  • to make it simple, let's say this are the connections I'm using:

eth0 - Management network (different network - 192.168.1.0/24)

eth1 - host1 (sdn network - 10.0.0.0/24 - host1 IP: 10.0.0.1)

eth2 - host 2 (ip 10.0.0.2)

eth4 - ODL (ip 10.0.0.200)

  • I'm able to ping/netcat from hosts to hosts, hosts - odl, odl - hosts

This is the configuration from my last try:

1- Create OVS bridge

$ovs-vsctl add-br br-testbed

(checking changes with $ovs-vsctl show)

2- Add interfaces to OVS bridge

$ovs-vsctl add-port br-testbed eth0

$ovs-vsctl add-port br-testbed eth1

$ovs-vsctl add-port br-testbed eth2

$ovs-vsctl add-port br-testbed eth3

(all interfaces zeroed $ifconfig ethX 0)

3- Assign IP to OVS bridge

$sudo ifconfig br-int 10.0.0.100 netmask 255.255.255.0

4- Add controller

$ovs-vsctl set-controller br-testbed tcp:10.0.0.200:6633

5- Bring up bridge

$ifconfig br-testbed up

6- Add route

$ip route add 10.0.0.0/24 dev br-testbed

What am I'm missing? Should I do things in a different way?

Since it's the 1st time I'm configuring OVS, do I have to configure any kind of database?

Is the static routing not being well defined on the OVS machine?

Any help is welcome. Thanks.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-12-15 08:35:31 -0800

runamuck gravatar image

On the centos side, make sure all interfaces are up:

$ sudo ifconfig eth0 up
$ sudo ifconfig eth1 up
$ sudo ifconfig eth2 up
$ sudo ifconfig eth4 up

I also noticed you skip eth3... is this by design?

Also, this may help:

$ sudo ovs-vsctl set bridge br-testbed protocols=OpenFlow13
$ sudo ovs-ofctl -O OpenFlow13 show br-testbed
$ sudo ovs-vsctl set controller br-testbed connection-mode=out-of-band
$ sudo ovs-vsctl list controller
edit flag offensive delete publish link more

Comments

Only saw this answer after posting the 1st update. Will give it a try. Thanks

Rui ( 2015-12-15 08:40:04 -0800 )edit

Skipped eth3 by mistake. Actually the names are like "enp13s0f1" and similar... Only used ethX to make the post more friendly

Rui ( 2015-12-15 08:41:52 -0800 )edit

Deleted the update done some minutes ago since the new status was related to a wrong used IP. Regarding this post from Runamuck, after applying these changes I'm getting: status : {last_error="Connection timed out", sec_since_disconnect="0", state=BACKOFF}

Rui ( 2015-12-15 08:53:36 -0800 )edit
0

answered 2016-08-17 08:54:42 -0800

damarana gravatar image

any update?

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-12-15 05:49:00 -0800

Seen: 1,505 times

Last updated: Aug 17 '16