Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

Request could not be completed because the relevant data model content does not exist

asked 2015-11-25 23:19:16 -0800

dongwenting gravatar image

updated 2015-11-25 23:23:21 -0800

I try Restconf API Explorer.

Request URL

http://192.168.1.4:8181/restconf/config/network-topology:network-topology/topology/flow%3A1/

Response Body

{
"errors": {
"error": [
  {
    "error-type": "application",
    "error-tag": "data-missing",
    "error-message": "Request could not be completed because the relevant data model content does not exist "
  }
  ]
 }
 }

Response Code

 404

Response Headers

{
"Content-Type": "application/json",
"Transfer-Encoding": "chunked",
"Server": "Jetty(8.1.15.v20140411)"
}

I don't know why, I can see topology flow:1 from the dlux.

edit retag flag offensive close merge delete

Comments

How did you resolve this ?

khan.jehanzeb ( 2016-09-10 12:09:54 -0800 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-26 05:21:15 -0800

Point one OF switch to the controller and connect, you'll be able to see the model.

edit flag offensive delete publish link more

Comments

If I am using Mininet with OpenDaylight how would I do this? Or what documentation should I read for this? Because, I'm having this problem with all config and most operational commands in the RestConf.

Zetheroth ( 2017-05-30 07:58:14 -0800 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-11-25 23:19:16 -0800

Seen: 1,473 times

Last updated: Nov 26 '15