Ask Your Question
0

Unable to connect opendaylight from mininet

asked 2014-09-08 02:57:12 -0700

anonymous user

Anonymous

Hello everyone, I have two ubuntu virtual machines. On one of them i have installed opendaylight and on the other I have mininet. I wish to simulate opendaylight via mininet, after starting opendaylight controller on the remote virtual machine I typed the following command on virtual machine having mininet in order controller will initiate a connection to the OVS element that is listening, ovs-vsctl show and then to set OVS element to attach to an active Daylight management controller gave the following command on mininet virtual machine sudo ovs-vsctl set-manager tcp:192.168.159.130:6640 where 192.168.159.130 is the ip of virtual machine having opendaylight controller and then in order to confirm connectivity I gave command ovs-vsctl show which gave output as: ovs-vsctl show dffa6719-ed75-4eff-9e63-736871d76c0c Manager "tcp:192.168.159.130:6640" ovs_version: "1.4.6" and then for making topology I gave following command on mininet virtual machine sudo mn --controller=remote,ip=[controller IP],port=[controller listening port] where controller ip is 192.168.159.130 the ip of one of the port of virtual machine having opendaylight controller which is Host-only and controller listening port is 6633 for checking the hosts connectivity in topology I did pingall but it gave output that the hosts are unreachable Also, the opendaylight UI ( https://127.0.0.1:8080 ) showed no built topology What is going wrong ?

edit retag flag offensive close merge delete

Comments

I am having the same issue. Did you get this working?

mlane706 ( 2014-12-12 10:45:55 -0700 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-12-28 06:54:22 -0700

bhavesh07 gravatar image

updated 2014-12-28 07:13:53 -0700

Stop the running controller and check for the port 6633 by running the command,

ps -eaf | grep ":6633"

If any of the service is running on this port, kill them by the command

sudo kill -9 pid #pid: Process ID of the running service

then, try to install these features:

opendaylight-user@root>feature:install odl-l2switch-switch odl-restconf odl-mdsal-apidocs

Now, start the mininet and check for connectivity between controller and mininet.

edit flag offensive delete publish link more
0

answered 2014-09-09 17:21:06 -0700

Madhusudhan gravatar image

updated 2014-09-09 17:30:45 -0700

I am not sure what is going on in your setup. I would ask you to refer/revisit the following links for bringing up the controller via mininet.

https://wiki.opendaylight.org/view/CrossProject:IntegrationGroup:CreateSystemTestEnvironment

I believe it is because of the wrong command at mininet console: It should be like the one below.

sudo mn --topo single,3 --controller 'remote,ip=<your controller="" ip="">,port=6653' --switch ovsk,protocols=OpenFlow13</your>

Hope this helps!

BR/Madhusudhan

edit flag offensive delete publish link more

Comments

Hi Madhu, I am also facing the same problem. I am using the right command in mininet. I have vm running in two seperate systems. In one vm karaf-controller is running and other vm in anothre system mininet is running. I am unable to connect them. I am able to ping between VMs. I am stuck.Please help

techdeveloper ( 2014-12-16 00:12:31 -0700 )edit

even though when I run both controller and mininet in same vm i am unable to connect.

techdeveloper ( 2014-12-16 00:13:52 -0700 )edit

Still not resolved. Is my controller listening in port 6633 or 6653?

techdeveloper ( 2014-12-16 21:14:42 -0700 )edit

The OpenFlow part of the controller will listen to both 6633 and 6653

Chris O'Shea ( 2014-12-28 15:13:11 -0700 )edit
0

answered 2016-06-26 23:58:04 -0700

sayed_adnan gravatar image

updated 2016-06-27 00:00:34 -0700

Hi....I do below steps which resolve the connectivity issue between the mininet and ODL via port 6633 :

first I clean the configuration :

$ cd distribution-karaf-0.4.0-Beryllium $ ./bin/karaf clean

then I installed the features again on below sequence as shown below :

opendaylight-user@root>feature:install odl-l2switch-switch odl-mdsal-apidocs odl-dlux-all

it take little time to install all it , around one minute

I re-run below command again at the mininet , the remote controller get connected successfully :

$ sudo mn --topo linear,3 --mac --controller=remote,ip=192.168.56.20,port=6633 --switch ovs,protocols=OpenFlow13

* Creating network Adding controller Adding hosts: h1 h2 h3 Adding switches: s1 s2 s3 Adding links: (h1, s1) (h2, s2) (h3, s3) (s2, s1) (s3, s2) Configuring hosts h1 h2 h3 Starting controller c0 Starting 3 switches s1 s2 s3 ... ** Starting CLI: mininet> mininet>

edit flag offensive delete publish link more

Comments

@sayed_adnan This issue have already been resolved.

bhavesh07 ( 2016-06-27 04:07:58 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
2 followers

Stats

Asked: 2014-09-08 02:57:12 -0700

Seen: 4,593 times

Last updated: Jun 27 '16