Ask Your Question
0

Unable to login through dlux

asked 2014-09-01 18:26:38 -0700

anonymous user

Anonymous

When I visit http://localhost:9000/#/login , no matter the ODL is running or not, the login process is failed with the output "unable to login" and no more details is provided. Can anyone help?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-09-01 23:08:02 -0700

Madhu gravatar image

It seems to be like a recent breakage. Please file a Bug in bugs.opendaylight.org .

edit flag offensive delete publish link more

Comments

Thanks very much for your reply. I'm not sure whether it's a bug or not as I haven't successfully ran DLUX on my environment. Did you get the same problem in your environment?

hardfish82 ( 2014-09-02 01:34:03 -0700 )edit

Yes. I saw the same problem. i have temporarily fixed it in my local branch : https://git.opendaylight.org/gerrit/10632 and have submitted it for review. you can use this simple patch and try it out. Due to the current changes in dlux, this patch might morph into a more usable one.

Madhu ( 2014-09-02 06:25:03 -0700 )edit

I am also facing the same issue in my dev setup. during karaf start I see couple of errors like ContainerBase | 273 - org.apache.juli.extras - 7.0.53.v201406060720 | ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/oauth2/federation]] at org.apache.catalina.util.LifecycleBase .. org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[org.eclipse.osgi-3.8.2.v20130124-134944.jar:] at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[org.eclipse.osgi-3.8.2.v20130124-134944.jar:] Caused by: java.lang.NoClassDefFoundError: org/apache/oltu/oauth2/common/exception/OAuthSystemException at java.lang.Class.getDeclaredMethods0(Native Method)[:1.7.0_65]

anu.nair ( 2014-11-06 15:22:31 -0700 )edit

Same error here. Any help would be appreciated! The log shows this afterwards: 2014-11-10 14:14:53,456 | ERROR | Event Dispatcher | StandardWebApplication | 275 - slf4j.api - 1.7.2 | Failed to start web application at context path '/oauth2/federation' org.eclipse.gemini.web.core.spi.ServletContainerException: Web application at '/oauth2/federation' cannot be added to the host. at org.eclipse.gemini.web.tomcat.internal.TomcatServletContainer.startWebApplication(TomcatServletContainer.java:128)

pedrocos ( 2014-11-10 07:18:59 -0700 )edit
0

answered 2014-11-11 02:43:11 -0700

pedrocos gravatar image

updated 2014-11-11 03:47:44 -0700

I eventually solved the problem adding an import package - org.apache.oltu.oauth2.common.exception;version="[1.0,2)", - to the aaa-authn-federation project's pom.xml, that was missing on the manifest.mf.

edit flag offensive delete publish link more
Login/Signup to Answer

Stats

Asked: 2014-09-01 18:26:38 -0700

Seen: 1,220 times

Last updated: Nov 11 '14