Ask Your Question
0

Remote Netconf Server Initialization Failed : Disconnecting from device

asked 2014-08-25 02:05:43 -0700

Sachi gravatar image

updated 2014-08-25 02:08:11 -0700

Remote Netconf Server Connection With new cloned Opendaylight controller(Cloned on Aug 21, 2013) failed.

Steps followed to replicate the issue:

  1. Clone new Opnedaylight controller
  2. Created the xml file and added the file in configuration/initial folder of the distribution that we are running
  3. Added the remote device configuration yang files in cache/schema directory
  4. Run the controller

Running the controller failed to initialize sal and throws the following error as below:

2014-08-25 14:21:57.363 IST [remote-connector-processing-executor-2] WARN o.o.c.s.c.n.NetconfStateSchemas - RemoteDevice{m10sachi}: Unable to detect available schemas, get to (urn:ietf:params:xml:ns:yang:ietf-netconf-monitoring?revision=2010-10-04)netconf-state/(urn:ietf:params:xml:ns:yang:ietf-netconf-monitoring?revision=2010-10-04)schemas was empty 2014-08-25 14:21:57.371 IST [remote-connector-processing-executor-3] ERROR o.o.c.s.c.netconf.NetconfDevice - RemoteDevice{m10sachi}: Initialization in sal failed, disconnecting from device java.lang.IllegalStateException: RemoteDevice{m10sachi}: No more sources for schema context at org.opendaylight.controller.sal.connect.netconf.NetconfDevice$RecursiveSchemaSetup.setUpSchema(NetconfDevice.java:305) [bundlefile:na] at org.opendaylight.controller.sal.connect.netconf.NetconfDevice$RecursiveSchemaSetup.run(NetconfDevice.java:294) [bundlefile:na] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [na:1.7.055] at java.util.concurrent.FutureTask.run(FutureTask.java:262) [na:1.7.055] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [na:1.7.055] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [na:1.7.055] at java.lang.Thread.run(Thread.java:744) [na:1.7.0_55] 2014-08-25 14:21:57.372 IST [remote-connector-processing-executor-3] WARN o.o.c.s.c.n.l.NetconfDeviceCommunicator - RemoteDevice{m10sachi}: Session terminated Session closed

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-14 02:29:46 -0700

Hi,

I think you also should specify your Yang files in the netconf connector xml file using:

<yang-module-capabilities xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">
  <capability xmlns="urn:opendaylight:params:xml:ns:yang:controller:md:sal:connector:netconf">
    urn:ietf:params:xml:ns:yang:ietf-inet-types?module=ietf-inet-types&revision=2010-09-24
  </capability>
</yang-module-capabilities>

(And adjust this to your own Yang files)

edit flag offensive delete publish link more
0

answered 2015-08-10 07:11:55 -0700

hello,did you solve this problem? im facing this problem,i can not add netconf server in restful api,it is show that connect false,so i need some help

edit flag offensive delete publish link more
Login/Signup to Answer

Stats

Asked: 2014-08-25 02:05:43 -0700

Seen: 2,066 times

Last updated: Aug 10 '15