Ask Your Question
0

node not added to OVSDB MD-SAL data store

asked 2015-10-02 03:55:25 -0700

updated 2015-10-02 04:09:26 -0700

Hi,

I am using the distribution-karaf-0.3.1-Lithium-SR1 package, to try out hte OVSDB southbound interface, together with mininet.

I have manage to install all features:

opendaylight-user@root>feature:list | grep ovsdb
odl-ovsdb-all                                 | 1.1.1-Lithium-SR1   | x         | ovsdb-1.1.1-Lithium-SR1                    | OpenDaylight :: OVSDB :: all                      
odl-ovsdb-library                             | 1.1.1-Lithium-SR1   | x         | ovsdb-1.1.1-Lithium-SR1                    | OVSDB :: Library                                  
odl-ovsdb-schema-openvswitch                  | 1.1.1-Lithium-SR1   | x         | ovsdb-1.1.1-Lithium-SR1                    | OVSDB :: Schema :: Open_vSwitch                   
odl-ovsdb-schema-hardwarevtep                 | 1.1.1-Lithium-SR1   | x         | ovsdb-1.1.1-Lithium-SR1                    | OVSDB :: Schema :: hardware_vtep                  
odl-ovsdb-plugin                              | 1.1.1-Lithium-SR1   | x         | ovsdb-1.1.1-Lithium-SR1                    | OpenDaylight :: OVSDB :: Plugin                   
odl-ovsdb-northbound                          | 0.7.1-Lithium-SR1   | x         | ovsdb-1.1.1-Lithium-SR1                    | OpenDaylight :: OVSDB :: Northbound               
odl-ovsdb-compatibility-layer                 | 1.1.1-Lithium-SR1   |           | ovsdb-1.1.1-Lithium-SR1                    | OpenDaylight :: OVSDB :: Plugin Compatibility Laye
odl-ovsdb-openstack                           | 1.1.1-Lithium-SR1   |           | ovsdb-1.1.1-Lithium-SR1                    | OpenDaylight :: OVSDB :: OpenStack Network Virtual
odl-ovsdb-southbound-api                      | 1.1.1-Lithium-SR1   | x         | odl-ovsdb-southbound-1.1.1-Lithium-SR1     | OpenDaylight :: southbound :: api                 
odl-ovsdb-southbound-impl                     | 1.1.1-Lithium-SR1   | x         | odl-ovsdb-southbound-1.1.1-Lithium-SR1     | OpenDaylight :: southbound :: impl                
odl-ovsdb-southbound-impl-rest                | 1.1.1-Lithium-SR1   | x         | odl-ovsdb-southbound-1.1.1-Lithium-SR1     | OpenDaylight :: southbound :: impl :: REST        
odl-ovsdb-southbound-impl-ui                  | 1.1.1-Lithium-SR1   | x         | odl-ovsdb-southbound-1.1.1-Lithium-SR1     | OpenDaylight :: southbound :: impl :: UI

start-up mininet: sudo mn --controller=remote,ip=127.0.0.1 --topo=linear,3 --switch ovsk,protocols=OpenFlow13 (pingall is working fine)

and set the manager address for ODL.

OVS looks correctly configured, ovs-vsctl show output:

0b69db46-c2b5-401b-8630-cfb7e0405afb
    Manager "tcp:127.0.0.1:6640"
        is_connected: true
    Bridge "s3"
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "s3-eth1"
            Interface "s3-eth1"
        Port "s3"
            Interface "s3"
                type: internal
        Port "s3-eth2"
            Interface "s3-eth2"
    Bridge "s1"
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "s1-eth1"
            Interface "s1-eth1"
        Port "s1"
            Interface "s1"
                type: internal
        Port "s1-eth2"
            Interface "s1-eth2"
    Bridge "s2"
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "s2-eth3"
            Interface "s2-eth3"
        Port "s2"
            Interface "s2"
                type: internal
        Port "s2-eth1"
            Interface "s2-eth1"
        Port "s2-eth2"
            Interface "s2-eth2"
    ovs_version: "2.3.2"

However, when querying the md-sal operational datastore, using :

http://localhost:8181/restconf/operational/network-topology:network-topology/

the ovsdb:1 topology stays empty. But the flow:1 topology is filled normally.

The ovsdb part is limited to (not to list the complete RESTCONF output):

<topology>
   <topology-id>ovsdb:1</topology-id>
</topology>

I would expect at least my local OVS node here.

Is there something that I am doing wrong?

Thanks for your support.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-05 02:56:13 -0700

updated 2015-10-05 02:58:17 -0700

Found the solution myself:

odl-ovsdb-plugin and odl-ovsdb-southbound-impl cannot run together.

I disabled odl-ovsdb-plugin using: feature:uninstall odl-ovsdb-plugin

After a restart, the ovsdb topology became visible.

Also see: https://wiki.opendaylight.org/view/OpenDaylightOVSDB:LithiumIntegration_Test#Incompatibilities

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-10-02 03:55:25 -0700

Seen: 335 times

Last updated: Oct 05 '15