Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

OpenDaylight doesn't create br-int

asked 2015-09-29 06:18:46 -0800

krijan gravatar image

Hi everybody,

i'm using ODL Lithium with OpenStack Kilo, having several compute nodes with OVS 2.1.3. I integrated ODL and OpenStack as described here:

https://wiki.opendaylight.org/view/OpenStackandOpenDaylight

Each OVS Instance is connected to the Controller as desired, but there is no br-int created automatically. Nothing is created at all. If i manually create br-int, then it is displayed correctly in ODL DLUX, then I can also launch VMs, but they do not get assigned IPs. I can't find any errors in any log files.

The ML2-Config on the Controlnode is configured as follows:

type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers = opendaylight

[ml2_odl]
password = password
username = admin
url = http://192.168.0.10:8080/controller/nb/v2/neutron

Most of the rest is commented out, i find it very difficult to find out what is needed exactly...

I searched through many other posts but did not find help, mostly because there are thousands of different versions and protocols and none of them really fit my environment.

I'd be really happy if someone could help me.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-09-29 20:42:58 -0800

Ashwini_Mhatre gravatar image

Hi , have you instlled openstack specific features?? if not please install following features: feature:install odl-base-jackson odl-adsal-compatibility odl-ovsdb-openstack odl-ovsdb-northbound

Regards, Ashwini mhatre

edit flag offensive delete publish link more
0

answered 2015-09-30 04:49:46 -0800

krijan gravatar image

updated 2015-09-30 04:50:00 -0800

Hi Ashwini,

thanks for your suggestion. I solved the problem, which actually had to do with the features. In Lithium, only the feature odl-ovsdb-openstack shall be installed, nothing else. All the other packages produce strange errors in Lithium. I now have installed the following features:

odl-ovsdb-openstack odl-restconf odl-l2switch-switch odl-mdsal-apidocs odl-dlux-core

This works fine for me.

edit flag offensive delete publish link more
Login/Signup to Answer

Stats

Asked: 2015-09-29 06:18:46 -0800

Seen: 516 times

Last updated: Sep 30 '15