Ask Your Question
0

lose ssh connection with my VM

asked 2015-09-27 22:45:34 -0700

zhaojun gravatar image

updated 2015-09-27 22:49:44 -0700

Hello

I install opendaylight lithium and install several features listed as follows

opendaylight-user@root>feature:install odl-restconf

opendaylight-user@root>feature:install odl-openflowplugin-all

opendaylight-user@root>feature:install odl-mdsal-apidocs

opendaylight-user@root>feature:install odl-dlux-all

opendaylight-user@root>feature:install odl-adsal-northbound

I also have a VM running openvswitch. the VM has only one port called eth0, and I create a bridge called s1, I add port eth0 to s1.

Now I can use ssh to connect to my VM.

But as soon as I set openvswitch VM's controller to opendaylight, I lose ssh connection with my VM!

I do not know why?

Thanks

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-09-28 02:01:16 -0700

I assume the OpenFlowPlugin modifies the flow table in such a way, that eth0 traffic is dropped, unless there is a specific rule for it. I recommend you add a second interface for management, which is not added to s1, and use the IP address on it to SSH into the VM.

edit flag offensive delete publish link more
0

answered 2015-09-28 02:28:22 -0700

You should not terminate your eth0 to the ovs bridge. So when you attached the eth0 to the ovs then the setup will look like this

+--------------------------------------------------+
|                                                  |
|  +------------+                                  |
|  |            |                                  |
|  | Network    |                                  |
|  | Stack      |                                  |
|  |            |         +---------------+        |
|  |            |    +----+  OpenVwitch   |        |
|  |            |    |    +---------------+        |
|  +------------+    |                             |
+--------------------+-----------------------------+
                     |eth0                   
                     |                       
                  +---+--------+                                   
                  |            |                  
                  |   ODL      |                  
                  |            |                              
                  +------------+

So all the traffic is going through not by the networking stack, that's why you are not able to do ssh to the machine.

edit flag offensive delete publish link more
0

answered 2015-09-28 06:52:50 -0700

zhaojun gravatar image

Thanks all the above answers! And here I post what I did to solve this problem.

The difference between before and after setting OVS controller to opendaylight is that opendaylight controller will delete an openflow rule listed bellow:

duration=4168s, npackets=297, nbytes=55096, priority=0,actions=NORMAL

So traffic destined to ovs will be dropped except packets coming from controller!

So what you should do is to add this flow rule to the ovs, and you will ssh to it!

Thanks

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-09-27 22:45:34 -0700

Seen: 171 times

Last updated: Sep 28 '15