Ask Your Question
0

Failed to find odl-aaa-netconf-plugin in 0.3.0?

asked 2015-09-08 21:20:07 -0700

Mandeep gravatar image

I have pulled latest controller code from origin/master (I am not using any pre-build distribution).

While trying to install 'odl-netconf-connector-ssh' feature, which internally depends and tries to install 'odl-aaa-netconf-plugin' but controller failed to find this feature with 0.3.0-SNAPSHOT.

I cross checked and noticed odl-aaa-netconf-plugin is no longer available in 0.3.0 version in repository.

Also, tried to change controller dependency to 0.2.0 version, controller build goes fine but failed while installing netconf-connector-ssh. This time different stack trace exceptions.

Looks like, netconf-connector-ssh is updated based on latest aaa code base and using new plugin, but aaa repository is still not have that changes to reflect in my setup.

Anyone have seen/solved this problem?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-09-08 22:35:06 -0700

jamoluhrsen gravatar image

One thing that's happening for this current (aka master, aka Beryllium) release is to move netconf in to it's own project and out of the controller project.

https://lists.opendaylight.org/pipermail/discuss/2015-August/005519.html

I think it's ongoing still and an email came across the release list just today asking for other projects to do their part in the migration:

https://lists.opendaylight.org/pipermail/release/2015-September/003701.html

I think it's probably safe to say that you are bumping in to a work in progress and it's expected for now, if you are working from master.

edit flag offensive delete publish link more

Comments

Thanks for update. Agree. Was just looking to play around with Beryllium :) Guess need to move to Lithium for my netconf RnD.

Mandeep ( 2015-09-09 00:01:25 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-09-08 21:20:07 -0700

Seen: 42 times

Last updated: Sep 08 '15