Ask Your Question
0

Neutron Not working with ODL

asked 2015-09-07 07:12:02 -0700

Krishnasharma gravatar image

updated 2015-09-07 08:45:37 -0700

Hi All,

I am working on integration of ODL(Helium SR3 distribution) with Openstack. Openstack(started using devstack) & OVS are running on one system and ODL is running on another system. As it's evident from all the possible sources available over net, I should be installing necessary packages. I have installed following packages odl-base-all odl-aaa-authn odl-restconf odl-adsal-northbound odl-mdsal-apidocs odl-l2switch-switch odl-ovsdb-all

Now I installed openstack using devstck and is running fine. But I see that openstack tries to communicate to ODL on port 8080 with URL as "odl-ip-addr":8080/controller/nb/v2/neutron.

But this URL is showing 404 error which says that required service is not available on that port. I tried to install odl-nfs-all as well but still dint succeed.

Output of web:list command looks something like this

opendaylight-user@root>web:list

ID | State | Web-State | Level | Web-ContextPath | Name

330 | Active | Deployed | 80 | /oauth2 | aaa-authn-sts (0.1.3.Helium-SR3)
333 | Active | Deployed | 80 | /auth | aaa-idmlight (0.1.3.Helium-SR3)
342 | Active | Deployed | 80 | /oauth2/federation | aaa-authn-federation (0.1.3.Helium-SR3)
346 | Active | Deployed | 80 | /restconf MD SAL Restconf Connector (1.1.3.Helium-SR3)
383 | Active | Failed | 80 | /controller/nb/v2/connectionmanager | connectionmanager.northbound (0.1.5.Helium-SR3)
384 | Active | Failed | 80 | /controller/nb/v2/flowprogrammer | flowprogrammer.northbound (0.4.5.Helium-SR3)
385 | Active | Failed | 80 | /controller/nb/v2/hosttracker | hosttracker.northbound (0.4.5.Helium-SR3)
386 | Active | Failed | 80 | /controller/nb/v2/networkconfig/bridgedomain | networkconfig.bridgedomain.northbound (0.0.6.Helium-SR3) 387 | Active | Failed | 80 | /controller/nb/v2/neutron | networkconfig.neutron.northbound (0.4.5.Helium-SR3)
388 | Active | Failed | 80 | /controller/nb/v2/staticroute | forwarding.staticrouting.northbound (0.4.5.Helium-SR3)
389 | Active | Failed | 80 | /controller/nb/v2/statistics | statistics.northbound (0.4.5.Helium-SR3)
390 | Active | Failed | 80 | /controller/nb/v2/subnetservice | subnets.northbound (0.4.5.Helium-SR3)
391 | Active | Failed | 80 | /controller/nb/v2/switchmanager | switchmanager.northbound (0.4.5.Helium-SR3)
392 | Active | Failed | 80 | /controller/nb/v2/topology | topology.northbound (0.4.5.Helium-SR3)
393 | Active | Failed | 80 | /controller/nb/v2/usermanager | usermanager.northbound (0.0.5.Helium-SR3)
394 | Active | Deployed | 80 | /apidoc | MD SAL Rest Api Doc Generator (1.1.3.Helium-SR3)
409 | Active | Failed | 80 | /ovsdb/nb | OpenDaylight OVSDB Northbound APIs (0.6.3.Helium-SR3)
418 | Active | Failed | 80 | /controller/nb/v2/vtn | manager.northbound (0.2.3.Helium-SR3)
opendaylight-user@root>

I am using Helium SR3 distribution version and have verified that port 8080 is up and listening.

When I try to create network from Openstack UI , I end up getting "Createnetworkpostcommit" falied. I have ensured connectivity from both the systems.

This is the error log when I am creating network from Openstack CLI

devstack@devstack:~/devstack$ neutron net-create --debug --tenant-id c69a198cb6ec436591e96dce4a68aa81 private DEBUG: keystoneclient.session REQ: curl -g -i -X GET http://192.168.0.112:35357/v2.0 -H "Accept: application/json" -H "User-Agent: python-keystoneclient" DEBUG: keystoneclient.session RESP: [200] date: Mon, 07 Sep 2015 15:30:58 GMT content-type: application/json content-length: 424 vary: X-Auth-Token server: Apache/2 ... (more)

edit retag flag offensive close merge delete

Comments

Just a Suggession: I am not familiar with openstack, but looks like Openstack trying to connect to ODL using AD-SAL URL ("odl-ip-addr":8080/controller/nb/v2/neutron) but Helium SR3 suppose to be MD-SAL (some thing starting with "odl-ip-addr":8181/). Assuming "odl-adsal-northbound" should have AD-SAL northbound on 8080 or 8181? I am not sure if you can or cannot, but if you aware of openstack well try to change "odl-ip-addr":8080/controller/nb/v2/neutron" to similar URL I guess like "odl-ip-addr":8181/nb/v2/neutron".

Mandeep ( 2015-09-07 07:59:42 -0700 )edit

Thanks Mandeep for taking look into my issue. But Helium version also comes with adsal to mdsal compatible features. The URL is not accessible when I access it from browser or using CURL command as well. Ideally it should respond for curl command curl -u admin:admin http://ip-addr:8080/controller/nb/v2/neutron/networks with details of available network. But I get error message. As per suggestion I did check with 8181 port as well but it doesnt click. Thanks for you time Mandeep.

Krishnasharma ( 2015-09-07 08:29:48 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-09-08 08:31:27 -0700

90.suman gravatar image

updated 2015-09-08 08:32:02 -0700

I think this file /etc/neutron/plugins/ml2/ml2_conf.ini uri for controller your have mentioned wrong port no. Please check if it is 8080. If it correct, you can try one more thing, dont try installing all odl-ovsdb-all just odl-ovsdb-openstack odl-ovsdb-northbound will suffice.

edit flag offensive delete publish link more

Comments

Hi Suman, URL has port as 8080. I did try with only these features odl-base-all odl-aaa-authn odl-restconf odl-nsf-all odl-adsal-northbound odl-mdsal-apidocs odl-ovsdb-openstack odl-ovsdb-northbound odl-dlux-core Still no luck. Any further suggestions will be helpful.

Krishnasharma ( 2015-09-08 23:56:26 -0700 )edit

What's the output of "netstat -nap |grep 8080".If TCP port is listening, check which process is running on it using the PID. If it is java process then it is fine.Make sure swift is not running on this port Secondly, What is your tenent network type, is it VLAN or VxLAN? I doubt it works with VLAN.

90.suman ( 2015-09-09 00:12:05 -0700 )edit

root@ODLBuildMachine:~/krishna/odl# netstat -nap | grep 8080 tcp6 0 0 :::8080 :::* LISTEN 10384/java root@ODLBuildMachine:~/krishna/odl# ps -eaf | grep 10384 tomcat7 10384 2120 0 Sep07 ? 00:05:46 /usr/lib/jvm/java-7-openjdk-amd64//bin/java -Djava.util.logging.config.file=/var/lib/tomcat7/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.awt.headless=true -Xmx128m -XX:+UseConcMarkSweepGC -Djava.endorsed.dirs=/usr/share/tomcat7/endorsed -classpath /usr/share/tomcat7/bin/bootstrap.jar:/usr/share/tomcat7/bin/tomcat-juli.jar -Dcatalina.base=/var/lib/tomcat7 -Dcatalina.home=/usr/share/tomcat7 -Djava.io.tmpdir=/tmp/tomcat7-tomcat7-tmp org.apache.catalina.startup.Bootstrap start root 27196 10526 0 14:50 pts/9 00:00:00 grep --color=auto 10384 root@ODLBuildMachine:~/krishna/odl# It's java which is running on 8080. Tenant network type is VxLAN. Should it be VLAN ?

Krishnasharma ( 2015-09-09 02:22:08 -0700 )edit

I even checked with vlan as tenant network type in ml2_conf.ini But it still says post commit failed. Looks like there is issue with ODL listening to this request.

Krishnasharma ( 2015-09-09 02:49:35 -0700 )edit

I have the same setup with VxLAN.Even I had problem with tenant n/w type VLAN,I guess ODL doesn't support VLAN. Btw did you checked data/logs/karaf.log , any error there?

90.suman ( 2015-09-09 03:24:21 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-09-07 07:12:02 -0700

Seen: 724 times

Last updated: Sep 08 '15