Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode


Exception in thread "config-pusher"

asked 2015-09-02 04:01:22 -0700

anhtt gravatar image

I develop application base on ncmount application.

I want to create a SSH connection to remote host from controller via JSCH library. So I add JSCH dependency to impl/pom.xml


In listNodes() method of, I added follow code.

    try {
        JSch jsch = new JSch();
        Session session = jsch.getSession("username", "hostname", 22);
        java.util.Hashtable config = new java.util.Hashtable();
        config.put("StrictHostKeyChecking", "no");
        session.connect(3 * 1000); // making a connection with timeout.

    } catch (Exception e) {

Compile OK, but when I run application, the following error occurred

Exception in thread "config-pusher" java.lang.IllegalStateException: Unable to push configuration due to missing yang models. Required yang models that are missing: [urn:opendaylight:params:xml:ns:yang:ncmount:impl?module=ncmount-impl&revision=2014-12-10] at org.opendaylight.controller.config.persist.impl.ConfigPusherImpl.waitForCapabilities( at org.opendaylight.controller.config.persist.impl.ConfigPusherImpl.pushConfigWithConflictingVersionRetries( at org.opendaylight.controller.config.persist.impl.ConfigPusherImpl.internalPushConfigs( at org.opendaylight.controller.config.persist.impl.ConfigPusherImpl.processSingle( at org.opendaylight.controller.config.persist.impl.ConfigPusherImpl.process( at org.opendaylight.controller.config.persist.impl.osgi.ConfigPersisterActivator$ at Caused by: org.opendaylight.controller.config.persist.impl.ConfigPusherImpl$NotEnoughCapabilitiesException: Not enough capabilities for ncmount.xml(odl-ncmount-ui,odl-ncmount-ui). Expected but not found: [urn:opendaylight:params:xml:ns:yang:ncmount:impl?module=ncmount-impl&revision=2014-12-10] at org.opendaylight.controller.config.persist.impl.ConfigPusherImpl.waitForCapabilities( ... 6 more

Please help me to solve this problem.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2015-09-02 08:24:01 -0700

Colin Dixon gravatar image

What version of OpenDaylight are you using? This is a bug that's known to exist in Helium, but is fixed in Lithium. We've also recently fixed (at least one manifestation of) it in Helium-SR4. That progress is tracked here:

edit flag offensive delete publish link more

answered 2015-09-02 19:25:09 -0700

anhtt gravatar image

updated 2015-09-02 19:26:20 -0700

Hi Colin Dixon,

Thanks for your help.But this problem is not bug-id 4050. My problem is using thirty party plugin. Refer to this link

I added following configuration into impl/pom.xml and now it worked.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2015-09-02 04:01:22 -0700

Seen: 730 times

Last updated: Sep 02 '15