Ask Your Question
0

VTN - mininet not creating switches

asked 2015-08-25 04:07:28 -0700

Ufuntu gravatar image

Hi,

Can anyone advise why mininet would not be creating the switches for a custom topology? I have ran through the VTN L2networkwithsinglecontroller as per the tutorial:VTNCoordinator:RestApi:HowtoconfigureL2NetworkwithSingleController) but when I try the multi-controller tutorial, everything seems to work o.k. except when I "sudo ovs-vsctl show" in mininet there are no switches available?

I used the custom script from the tutorial, and as I said, mininet appears to connect to both controllers and create the network without issue, but then no switches are actually created?

Should I manually set the ovs manager on the controllers or mininet (e.g. sudo ovs-vsctl set-manager tcp:"ActualNodeIP":6640), or is there possibly a ODL Karaf module besides "odl-vtn-manager-rest" required?

Thank you in advance for any advice given.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-08-27 03:13:19 -0700

balakrishnan gravatar image

please check the controller IP's are changed in the multitree.py script before creating topology. we have tested the multicontroller tutorial for VTN it was working fine in our environment. could you please tell me which karaf distribution your using. after creating mininet topology please execute below command in both controller see your able to get topology information curl -v --user "admin":"admin" -H "Accept: application/json" -H "Content-type: application/json" -X GET http://10.106.138.249:8282/restconf/operational/vtn-topology:vtn-topology { "vtn-topology": { "vtn-link": [ { "destination": "openflow:1:1", "link-id": "openflow:2:3", "source": "openflow:2:3" }, { "destination": "openflow:1:2", "link-id": "openflow:3:3", "source": "openflow:3:3" }, { "destination": "openflow:3:3", "link-id": "openflow:1:2", "source": "openflow:1:2" }, { "destination": "openflow:2:3", "link-id": "openflow:1:1", "source": "openflow:1:1" } ] } } "sudo ovs-vsctl show" will list the switches connected to the controller as below you are getting only mininet version could be mininet issue. mininet@mininet-only:~$ sudo ovs-vsctl show [sudo] password for mininet: dedcbf5a-b730-4937-b453-6a36246917ae Bridge "s2" Controller "tcp:10.106.138.249:6633" is connected: true Controller "ptcp:6635" failmode: secure Port "s2-eth2" Interface "s2-eth2" Port "s2-eth3" Interface "s2-eth3" Port "s2" Interface "s2" type: internal Port "s2-eth1" Interface "s2-eth1" ...

edit flag offensive delete publish link more
0

answered 2015-08-28 10:00:30 -0700

Ufuntu gravatar image

updated 2015-08-28 10:01:19 -0700

Thanks for the reply,

I double checked that the controller ip's were changed in mininet and they were. When I enter the above cURL command in both ODL 1 & 2 the only response is {"vtn-topology":{}}

I have pasted here the output from mininet. I notice there is no port number after my ODL ip addresses, as there is when using a single controller? mininet@mininet:~/mininet/mininet$ sudo python multitree.py * Creating remote controller: c1 (192.168.56.110) Creating remote controller: c2 (192.168.56.120) Creating network Adding hosts: h1 h2 h3 h4 h5 h6 h7 h8 Adding switches: s1 s2 s3 s4 s5 s6 Adding links: (s1, s2) (s1, s3) (s1, s4) (s2, h1) (s2, h2) (s3, h3) (s3, h4) (s4, s5) (s4, s6) (s5, h5) (s5, h6) (s6, h7) (s6, h8) Configuring hosts h1 h2 h3 h4 h5 h6 h7 h8 Starting network Starting controller: c1 + Starting switches ... s1 s2 s3 Starting controller: c2 + Starting switches ... s4 s5 s6 Running CLI * Starting CLI:

I'm fairly sure my problem is with mininet/OVS as the single controller tutorial worked fine for me on the same machines

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-08-25 04:07:28 -0700

Seen: 323 times

Last updated: Aug 28 '15