Ask Your Question
0

Does vtn coordinator require OvS

asked 2015-08-13 07:57:09 -0700

Ufuntu gravatar image

Hi All,

Can anyone confirm if VTN coordinator requires Open vSwitch installed. In one sense, I would assume it would, because any node using Openv, I guess, would require it to be installed, but on the other hand VTN Coordinator uses it's own postgre database for it's data, so I am not sure if it also needs OvS.

I have ODL/VTn Manager installed on Ubuntu 14.04.03 and VTN Coordinator installed on CentOS 7. I also have mininet installed in it's own vm. Everything seems to work correctly:

ODL Lithium is up with "odl-vtn-manager-rest" installed

Mininet is up and connected to ODL using - sudo mn --controller=remote,ip="controller-ip" --topo tree,2

VTN Coordinator is up and using tutorial - https://wiki.opendaylight.org/view/Release/Lithium/VTN/HowTos/VTNHowToconfigureL2NetworkwithSingleController - all commands appear to work (Controller = operstatus:up, all logical ports are configured) except that the VTN created is operstatus:down

So does anyone know how to get VTN "operstatus:up" or if it is indeed an issues due to OvS not been installed

edit retag flag offensive close merge delete

Comments

HI, Did installing VTN open port 6633 for you?

sankettandulwadkar ( 2015-08-13 09:34:45 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-08-14 17:11:29 -0700

gvrangan gravatar image

Please chjeck the controller status and the VTN Coordinaotr is able to communite to VTN Manager in port:8282. Ensure no firewall is blocking the coordinaotr in the Manager VM. Please check the controller status is up, Only then the example will work

edit flag offensive delete publish link more

Comments

Actually I cloned my first vm and installed ovs on it and the example works now. It still does not work on the original coordinator vm without ovs? There was actually another issue on my first attempt as I had an error on 1 of my interface commands but ...

Ufuntu ( 2015-08-15 02:34:13 -0700 )edit

even after fixing that issue the first coordinator doesn't seem to work. I entered the commands as per the tutorial and everything (controller, vtn, vbrdige, interfaces) is operstatus:up but the hosts still can't ping one another? I'm ok now with my set up, but for others, installing ovs might help?

Ufuntu ( 2015-08-15 02:39:05 -0700 )edit

Is the topology showing up?, sometimes the problem is due to OVS version, you may have to install flows to forward table miss packets to controller. Maybe that is the issue.

gvrangan ( 2015-08-20 15:55:26 -0700 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-08-13 07:57:09 -0700

Seen: 191 times

Last updated: Aug 14 '15