Ask Your Question
0

HTTPS for ODL's REST interfaces

asked 2015-08-12 07:01:47 -0700

sankettandulwadkar gravatar image

Hi,

I am trying to add HTTPS for ODL's REST interfaces. I am following this link.

http://www.frank-durr.de/?p=75

I have created the KeyStore and put the path in configuration/tomcat-server.xml file in the "connector" section. I am not able to connect to port 8443. The port is not even up for some reason. Why is that so?

Restconf is up on 8181

sanket@sanket-ubuntu-odl:~$ curl -I -v http://localhost:8181/restconf/ * Hostname was NOT found in DNS cache * Trying 127.0.0.1... * Connected to localhost (127.0.0.1) port 8181 (#0)

HEAD /restconf/ HTTP/1.1 User-Agent: curl/7.37.1 Host: localhost:8181 Accept: /

< HTTP/1.1 401 Unauthorized HTTP/1.1 401 Unauthorized < WWW-Authenticate: Basic realm="opendaylight" WWW-Authenticate: Basic realm="opendaylight" < Content-Type: text/html;charset=ISO-8859-1 Content-Type: text/html;charset=ISO-8859-1 < Cache-Control: must-revalidate,no-cache,no-store Cache-Control: must-revalidate,no-cache,no-store < Content-Length: 1380 Content-Length: 1380 * Server Jetty(8.1.15.v20140411) is not blacklisted < Server: Jetty(8.1.15.v20140411) Server: Jetty(8.1.15.v20140411)

< * Connection #0 to host localhost left intact

But I dont see port 8443 up.

Here is the tomcat-server.xml

<Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
           maxThreads="150" scheme="https" secure="true"
           clientAuth="false" sslProtocol="TLS"
           keystoreFile="/home/sanket/KeyStore"
           keystorePass="changeit"/>

Am I missing something?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-08-27 13:26:08 -0700

updated 2015-08-27 13:27:14 -0700

Hello, the guide you are following is outdated. Here is a new guide working with the Lithium Artifacts:

RestConf SSL

edit flag offensive delete publish link more

Comments

But that worked. How so? Thank you for the answer though. Have you worked on SSL for OvS connection for OF? I have a couple questions up. If you dont mind, I would like for you to look into them and give me some pointers about the same. Thank you

sankettandulwadkar ( 2015-08-27 13:30:57 -0700 )edit

The file you are modifying is for Tomcat, however, RestConf is using Jetty. I suspect that installing the vtn-manager feature overrides jetty's RestConf URLs with VTN Tomcat URLs (note this is a supposition).

grmontpetit ( 2015-08-27 15:56:33 -0700 )edit

I see. That could definitely be a reason. I shall try following the wiki guidelines to check if it works without VTN

sankettandulwadkar ( 2015-08-28 06:26:56 -0700 )edit
0

answered 2015-08-13 06:50:25 -0700

sankettandulwadkar gravatar image

Needed VTN-MANAGER installation to open port 8443. Works now.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-08-12 07:01:47 -0700

Seen: 312 times

Last updated: Aug 27 '15