Ask Your Question
0

Unable to start blueprint container for bundle org.opendaylight.dlux.loader.implementation due to unresolved dependencies

asked 2015-07-28 04:50:35 -0700

karthik330 gravatar image

Hi, after installing l2switch-switch-ui , i am getting the following error in my log file.. i installed dlux-all also..it doesnt work..not able to see the UI in browser.. help me to solve this problem..

2015-07-28 11:37:34,410 | ERROR | rint Extender: 2 | BlueprintContainerImpl | 15 - org.apache.aries.blueprint.core - 1.4.2 | Unable to start blueprint container for bundle org.opendaylight.dlux.loader.implementation due to unresolved dependencies [(objectClass=org.osgi.service.http.HttpService)] java.util.concurrent.TimeoutException at org.apache.aries.blueprint.container.BlueprintContainerImpl$1.run(BlueprintContainerImpl.java:336)[15:org.apache.aries.blueprint.core:1.4.2] at org.apache.aries.blueprint.utils.threading.impl.DiscardableRunnable.run(DiscardableRunnable.java:48)[15:org.apache.aries.blueprint.core:1.4.2] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[:1.7.079] at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.079] at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178)[:1.7.079] at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292)[:1.7.079] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.079] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.079] at java.lang.Thread.run(Thread.java:745)[:1.7.0_79]

edit retag flag offensive close merge delete

Comments

Hi Karthick, Has the issue got resolved, myself facing the same issue!

root ( 2015-09-26 11:20:48 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-10-26 11:29:07 -0700

Hello,

Can you list all the features you're installing?

It seems there is a BUG in L2Switch in Boron release when installing for instance: odl-l2switch-switch then odl-dlux-node

Instead, it is recommended to install odl-l2switch-switch-ui

Hope this helps, Alexis

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-07-28 04:50:35 -0700

Seen: 651 times

Last updated: Oct 26 '16