Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode


How can I start the opendaylight controller running Helium SR3 version to run with openflow 1.0 version

asked 2015-07-20 00:50:13 -0700

anonymous user


I have an openflow switch which can run with Openflow 1.0 or with Openflow 1.3 versions. While starting the Open daylight controller how do I start the controller by specifying the openflow version.

I am using Helium SR3 version.

Thanks for the help in advance.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2015-07-20 04:58:14 -0700

Vishal Thapar gravatar image

updated 2015-07-20 04:59:12 -0700

When running bin/karaf try giving -of10 as a runtime option. Though I think it supports both modes and negotiates with switch. Did you get version negotiation error when connecting OpenFlow1.0 switch to ODL Helium SR3?

edit flag offensive delete publish link more


in Hellouim 3.0.1 did not worked, isn't any other way?

happysmile ( 2015-08-12 01:18:55 -0700 )edit

answered 2015-08-12 12:00:14 -0700

jamoluhrsen gravatar image

you shouldn't need any flags with Helium when starting karaf. once karaf is running, you can try starting the openflowplugin "feature:install odl-openflowplugin-flow-services-ui". After some time you can start your switch in either version (1.0 or 1.3) and point it at the controller IP and it should connect. If it does not connect, you might find some info/error with a clue in data/log/karaf.log If there is no info in the log and the switch is not connected, you might need to capture the OF Handshake packets (e.g. tcpdump) to debug futher.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools



Asked: 2015-07-20 00:50:13 -0700

Seen: 267 times

Last updated: Aug 12 '15