Ask Your Question
0

Delete Flow HTTP Response 410

asked 2015-07-14 09:14:15 -0700

rolecram gravatar image

Hi, When I send an HTTP DELETE FLOW (via REST API) sometimes (not always) I've got an HTTP Response 410 error (the flow is not deleted from the ODL nor the switch). I am sending five of six HTTP DELETE (one after one), can be this the cause of error? Any idea?

thank you in advance, marcelo

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2015-07-14 09:24:02 -0700

jamoluhrsen gravatar image

Hi Marcelo,

When you get this 410 error, do you see anything interesting in your data/log/karaf.log file?

Are you creating the flow with REST? If so, are you using the exact same flow data to DELETE it?

edit flag offensive delete publish link more

Comments

Hi jamo: Thanks for your response. I don´t see anything relation to this error in the ODL log file. On the other hand, I´m creating the flow via REST API and the flow inserted is exactly the same the flow I delete. This error ocurrs randomly. I´m using ODL Hydrogen

rolecram ( 2015-07-14 12:19:18 -0700 )edit

oh, if you are using hydrogen I don't think you'll get much support. Are you able to upgrade to the newly released Lithium? http://www.opendaylight.org/software/downloads if so, I'd be interested if your specific flow still has this periodic issue.

jamoluhrsen ( 2015-07-14 13:18:20 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-07-14 09:14:15 -0700

Seen: 26 times

Last updated: Jul 14 '15