Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

BGP-LS issues - LS NLRI from XRv 5.3.0 not showing in ODL

asked 2015-07-13 07:07:00 -0800

anonymous user

Anonymous

updated 2015-07-13 12:32:35 -0800

Hi!

I have configured a set of routers (XRv 5.3.0) all participating in a L2 IS IS network. I am advertising several node and link "Networks" to the ODL controller (distribution-karaf-0.3.1-20150713.080705-94) from XRv using BGP-LS, a few example below: *> [V][L2][I0x0][N[c64496][b7.7.7.7][s0000.0000.2222.02]]/336 *> [E][L1][I0x0][N[c64496][b7.7.7.7][s0000.0000.1111.00]][R[c64496][b7.7.7.7][s0000.0000.1111.01]]/576

But when using GET in ODL > Operational > Network-topology, the only thing I see under link-state is a router with part of a NET id that I am not even using: bgpls://IsisLevel2:0/type=node&as=64496&domain=117901063&router=0000.0000.1111 However, it is somehow also advertised from the XRv: [V][L1][I0x0][N[c64496][b7.7.7.7][s0000.0000.1111.01]]/336 50.50.50.2 Local 50.50.50.1

I don't get it why its not showing anything else...

Any suggestions?

Thanks in advance!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-14 01:36:17 -0800

Dana gravatar image

updated 2015-07-14 01:36:45 -0800

Try this wiki

edit flag offensive delete publish link more
Login/Signup to Answer

Stats

Asked: 2015-07-13 07:07:00 -0800

Seen: 199 times

Last updated: Jul 14 '15