Ask Your Question
0

getting error Some input files use or override a deprecated API

asked 2015-07-13 04:01:09 -0700

hjdeore gravatar image

updated 2015-08-30 14:50:27 -0700

Robert Varga gravatar image

HI Guys ,

I am getting error mentioned below for my program which i am trying to build in Lithium. This program works fine in Helium but getting error in Lithium version.

Some input files use or override a deprecated API.

/home/harish/Desktop/OpenDaylightLithium/l2switch-release-lithium/mynetworktopologyLithium/implementation/src/main/java/org/opendaylight/yang/gen/v1/urn/opendaylight/packet/mynetworktopology/impl/rev150525/MynetworktopologyModule.java:[11,8] org.opendaylight.yang.gen.v1.urn.opendaylight.packet.mynetworktopology.impl.rev150525.MynetworktopologyModule is not abstract and does not override abstract method canReuse(org.opendaylight.controller.config.spi.Module) in org.opendaylight.controller.config.spi.Module

Please share your ideas.

Thanks, Harish

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-08-30 14:54:16 -0700

Robert Varga gravatar image

This is related to a canReuse->canReuseInstance rename or similar -- I don't remember what it was, though :-(

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-07-13 04:01:09 -0700

Seen: 226 times

Last updated: Aug 30 '15