Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

hosts not pinging(l2switch issue maybe)

asked 2015-06-29 05:08:27 -0700

anonymous user

Anonymous

updated 2015-06-30 00:58:01 -0700

I have downloaded stable lithium's code from git-hub for - controller, l2switch and openflow plugin. After compiling all the three modules with maven , I am creating topology using mininet specifying remote controller by giving the below command: sudo mn --topo single,3 --mac --switch ovsk,protocols=OpenFlow13 --controller remote

After that I am trying to ping the hosts with the opendaylight controller ( ./karaf in assembly/bin).

Also, while trying to install feature on karaf console the below error is getting occurred:

opendaylight-user@root>feature:install odl-l2switch-all Error executing command: Could not start bundle mvn:org.opendaylight.yangtools/concepts/0.7.1-SNAPSHOT in feature(s) odl-yangtools-common-0.7.1-SNAPSHOT: The bundle "org.opendaylight.yangtools.concepts_0.7.1.SNAPSHOT [71]" could not be resolved. Reason: Missing Constraint: Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))"

Kindly help!!!!!!

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-06-30 00:12:24 -0700

hjdeore gravatar image

install feature , run this command on karaf console " feature:install odl-l2switch-switch " . It will resolve your issue. Also check for instance created using command "log:display | grep instance " . Once get created, you should be able to ping hosts.

edit flag offensive delete publish link more

Comments

Hi hjdeore, I am trying to install these features on karaf console but below error occurred: opendaylight-user@root>feature:install odl-l2switch-all Error executing command: Could not start bundle mvn:org.opendaylight.yangtools/concepts/0.7.1-SNAPSHOT in feature(s) odl-yangtools-common-0.7.1-SNAPSHOT: The bundle "org.opendaylight.yangtools.concepts_0.7.1.SNAPSHOT [71]" could not be resolved. Reason: Missing Constraint: Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))" I have tried to find the solution to the error but could not make it..so can you please comment or help what should be done in this case? Thanks !

Sona ( 2015-06-30 00:56:20 -0700 )edit

Please install JAVA version 1.7 . It does not support JAVA 1.8.

hjdeore ( 2015-06-30 02:01:31 -0700 )edit

Previously java version used was 1.8 but now I am using the Java 1.7 itself though it is not working with this version also.

Sona ( 2015-06-30 02:59:45 -0700 )edit

have you installed l2switch feature use command feature:install odl-l2switch-switch

hjdeore ( 2015-07-01 00:58:33 -0700 )edit
0

answered 2015-09-27 01:58:17 -0700

Check this workaround suggested in this answer https://ask.opendaylight.org/question/4033/missing-constraint-while-starting-the-project/ It worked for me!

edit flag offensive delete publish link more
0

answered 2015-09-28 00:57:00 -0700

Error : Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))"

you don't have correct version of java set as $JAVA_HOME. If you try to echo $JAVA_HOME at terminal then you will see the version of java you are using.

If the $JAVA_HOME comes empty that means it is not set. set the java home using following command (ensure the path before setting it).

linux :

export JAVA_HOME=/usr/lib/jvm/java-1.7.0-openjdk-amd64

OSX:

export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home

to make it permanent put above line in your ~/.bashrc file. Now you can run the ODL.

edit flag offensive delete publish link more
Login/Signup to Answer

Stats

Asked: 2015-06-29 05:08:27 -0700

Seen: 192 times

Last updated: Sep 28 '15