Ask Your Question
0

getting error while using JSON JACKSON in Opendaylight

asked 2015-06-10 06:27:07 -0700

hjdeore gravatar image

Hi Guys,

I am trying to use JSON/JACKSON in one feature of l2switch, but i am getting below error while installing that feature in karaf

Error executing command: Could not start bundle mvn:org.opendaylight.l2switch.mynetworktopology/mynetworktopology-impl/0.1.0-Helium in feature(s) odl-l2switch-mynetworktopology-0.1.0-Helium: The bundle "org.opendaylight.l2switch.mynetworktopology.impl_0.1.0.Helium [278]" could not be resolved. Reason: Missing Constraint: Import-Package: com.fasterxml.jackson.databind; version="[2.5.0,3.0.0)"

i have mention dependency in pom.xml as

<dependency> <groupid>com.fasterxml.jackson.core</groupid> <artifactid>jackson-core</artifactid> <version>2.5.0</version> </dependency> <dependency> <groupid>com.fasterxml.jackson.core</groupid> <artifactid>jackson-databind</artifactid> <version>2.5.0</version> </dependency> <dependency> <groupid>com.fasterxml.jackson.core</groupid> <artifactid>jackson-annotations</artifactid> <version>2.5.0</version> </dependency>

though i am getting such error.

Any idea how to resolve this error.Please share.

Thanks, Harish

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-06-10 06:50:39 -0700

kunal gravatar image

Check this link : http://stackoverflow.com/questions/9776885/cant-start-osgi-bundle-because-import-cannot-be-resolved

edit flag offensive delete publish link more

Comments

can you be more specific for jackson only. I tried the solution mentioned on link but its not working. Still getting same error.

hjdeore ( 2015-06-11 02:44:14 -0700 )edit

issue resolved now. Thanks

hjdeore ( 2015-06-12 01:54:52 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-06-10 06:27:07 -0700

Seen: 203 times

Last updated: Jun 10 '15