Ask Your Question
0

When trying to install a Karaf feature

asked 2014-07-22 12:20:53 -0700

CobyS gravatar image

Hello, When trying to install the following Karaf feature I get the subsequent error message.

opendaylight-user@root>feature:install odl-mdsal-misc

Error executing command: Could not start bundle mvn:org.opendaylight.controller/sal-netconf-connector/1.1-SNAPSHOT in feature(s) odl-mdsal-misc-1.1-SNAPSHOT: Unresolved constraint in bundle org.opendaylight.controller.sal-netconf-connector [219]: Unable to resolve 219.0: missing requirement [219.0] osgi.wiring.package; (&(osgi.wiring.package=org.opendaylight.controller.config.threadpool)(version>=0.2.0)(!(version>=1.0.0)))

What is controller.config.threadpool?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-07-25 16:48:46 -0700

Madhu gravatar image

The Karaf Feature definitions are not complete at the time of this writing. This is a bug in the dependency definition in odl-mdsal-misc feature which depends on sal-netconf-connector, which inturn depends on the config.threadpool bundle and it is missing in the feature definition. Feel free to open bugs in bugs.opendaylight.org under the controller project.

For the question on the config.threadpool, please refer to https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Examples:Threadpool

and for the motivation for the config subsystem, please refer to : https://wiki.opendaylight.org/view/OpenDaylight_Controller:Config:Main

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2014-07-22 12:20:53 -0700

Seen: 1,270 times

Last updated: Jul 25 '14