Why doesn't Helium-SR3 support Openflow 1.0?

asked 2015-05-14 16:08:16 -0700

yaolin gravatar image

I know ovs-ofctl uses v1.0 by default. But why does ODL controller send ver_bitmap 0x04 (meaning it supports v1.3 ONLY)? Is there any configuration I can make for it to support both 1.0 and 1.3? I know I can use "-O Openflow13" to get around this issue. But I would rather not to type in this -O option for every command. Thanks.

root@MUSSDHUX20:/home/mtk10895# ovs-ofctl --log-file -v show br-int 2015-05-14T22:58:17Z|00001|vlog|INFO|opened log file /var/log/openvswitch/ovs-ofctl.log 2015-05-14T22:58:17Z|00002|streamunix|DBG|/var/run/openvswitch/br-int: connection failed (No such file or directory) 2015-05-14T22:58:17Z|00003|ofctl|DBG|connecting to unix:/var/run/openvswitch/br-int.mgmt 2015-05-14T22:58:17Z|00004|hmap|DBG|../lib/ofp-msgs.c:1013: 6 nodes in bucket (128 nodes, 64 buckets) 2015-05-14T22:58:17Z|00005|hmap|DBG|../lib/ofp-msgs.c:1013: 6 nodes in bucket (256 nodes, 128 buckets) 2015-05-14T22:58:17Z|00006|hmap|DBG|../lib/ofp-msgs.c:1013: 7 nodes in bucket (512 nodes, 256 buckets) 2015-05-14T22:58:17Z|00007|hmap|DBG|../lib/ofp-msgs.c:1013: 8 nodes in bucket (512 nodes, 256 buckets) 2015-05-14T22:58:17Z|00008|hmap|DBG|../lib/ofp-msgs.c:1013: 6 nodes in bucket (512 nodes, 256 buckets) 2015-05-14T22:58:17Z|00009|hmap|DBG|../lib/ofp-msgs.c:1013: 7 nodes in bucket (512 nodes, 256 buckets) 2015-05-14T22:58:17Z|00010|hmap|DBG|../lib/ofp-msgs.c:1013: 7 nodes in bucket (1024 nodes, 512 buckets) 2015-05-14T22:58:17Z|00011|hmap|DBG|../lib/ofp-msgs.c:1013: 6 nodes in bucket (1024 nodes, 512 buckets) 2015-05-14T22:58:17Z|00012|hmap|DBG|../lib/ofp-msgs.c:1013: 6 nodes in bucket (1024 nodes, 512 buckets) 2015-05-14T22:58:17Z|00013|hmap|DBG|../lib/ofp-msgs.c:1013: 7 nodes in bucket (1024 nodes, 512 buckets) 2015-05-14T22:58:17Z|00014|vconn|DBG|unix:/var/run/openvswitch/br-int.mgmt: sent (Success): OFPTHELLO (xid=0x1): version bitmap: 0x01 2015-05-14T22:58:17Z|00015|vconn|DBG|unix:/var/run/openvswitch/br-int.mgmt: received: OFPTHELLO (OF1.3) (xid=0x652e): version bitmap: 0x04 2015-05-14T22:58:17Z|00016|vconn|WARN|unix:/var/run/openvswitch/br-int.mgmt: version negotiation failed (we support version 0x01, peer supports version 0x04) 2015-05-14T22:58:17Z|00017|vconn|DBG|unix:/var/run/openvswitch/br-int.mgmt: sent (Broken pipe): OFPTERROR (OF1.3) (xid=0x0): OFPHFC_INCOMPATIBLE We support version 0x01, you support version 0x04, no common versions. ovs-ofctl: br-int: failed to connect to socket (Broken pipe)

root@MUSSDHUX20:/home/mtk10895# ovs-vsctl show e6cc25cc-f894-45f8-b83a-396a4ea6976b Manager "tcp:172.29.106.220:6640" isconnected: true Bridge br-int Controller "tcp:172.29.106.220:6633" isconnected: true fail_mode: secure Port br-int Interface br-int Port "tap825256a5-cb" tag: 1 Interface "tap825256a5-cb" type: internal Port patch-tun Interface patch-tun type: patch options: {peer=patch-int}

edit retag flag offensive close merge delete