Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

should q-agt should run in ODL devstack setup when all nodes are installed in seperate PC

asked 2014-07-03 07:34:45 -0700

chandralekha gravatar image

updated 2014-07-03 07:41:39 -0700

I have 2PCs 1. Controller Node +Opendaylight controller 2. Compute Node

Network connection: controller compute ----------- 12.76 12.28 ---------------- | |-------------------------| | | |-------------------------| | | | 0.5 0.6 | | ------------ -------------------

N/w 192.168.12.0 Mgmt N/w 20.0.0.0 Data

Controller and compute node have devstack icehouse and i have successfully performed ./stach.sh in both the nodes. odl virtualisation edition is running with version 1.3.

Services enabled for devstack_controller: all services are commented out in stackrc and placed the required services in the local.conf file =g-api,g-reg,n-api,n-crt,n-obj,n-cond,n-cpu,n-sch,n-xvnc,n-cauth,q-svc,q-dhcp,q-l3,q-agt,q-meta,q-metering,neutron, horizon,rabbit, mysql. Note: Iam running rabbit instead of qpidd.

Services enabled for devstack_compute: all services are commented out in stackrc and placed the required services in the local.conf file = neutron n-cpu quantum n-novnc q-agt

I performed the below changes and performed stack.sh in both controller node and compute node

compute node:

Compute Node: lib/neutronplugins/ml2: iniset /$QPLUGINCONFFILE ovs localip "20.0.0.6" lib/neutronplugins/openvswitchagent: iniset /$QPLUGINCONFFILE ovs localip "20.0.0.6" lib/neutronplugins/ofagentagent: iniset /$QPLUGINCONFFILE ovs local_ip "20.0.0.6"

Controller node: lib/neutronplugins/ml2: iniset /$QPLUGINCONFFILE ovs localip "20.0.0.5" lib/neutronplugins/openvswitchagent: iniset /$QPLUGINCONFFILE ovs localip "20.0.0.5" lib/neutronplugins/ofagentagent: iniset /$QPLUGINCONFFILE ovs local_ip "20.0.0.5"

After stacking a tunnel is created with 20.0 network in compute node, compute node is connected to odl controller. the tunnel creation in controller node toggles and when a vm instance is triggered a tunnel with network192.168 is created in br-int(wrong behavior) , because of this VM is not getting IP address.

Clarify whether q-agt should run in controller and compute node

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-04 03:35:34 -0700

chandralekha gravatar image

an integration setup replaces q-agt with opendaylight controller.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2014-07-03 07:34:45 -0700

Seen: 3,261 times

Last updated: Jul 03 '14