Ask Your Question
0

Class reloading is not supported

asked 2015-04-03 07:19:32 -0700

oaugizeau gravatar image

I'm new at OpenDayligth. I've started with the "step by step helloworld" example. I have a successful deployment. I want to upgrade the helo-impl bundle using a hot depoyment procedure (cold upgrade is fine) I've tried sereval ways (using an odr repo with cave,a nexus repo, copying bundle jar in /system local repo with a bundle:watch, ...) and I always have the same error:
org.opendaylight.yangtools.binding-generator-impl - 0.7.0.SNAPSHOT | Schema was not recreated. java.io.IOException: Resource /META-INF/yang/hello-impl.yang is missing

but with log level set to DEBUG, there is a previous message:

Caused by: java.lang.UnsupportedOperationException: Class reloading is not supported at org.opendaylight.yang.gen.v1.urn.opendaylight.params.xml.ns.yang.hello.impl.rev141210.AbstractHelloModuleFactory.handleChangedClass(AbstractHelloModuleFactory.java:71)[173:com.bcom.cubiqos.hello.impl:1.0.0.SNAPSHOT]

any idea? A karaf bug?

thanks in advanced, Best regards Olivier

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-06-13 16:04:13 -0700

https://bugs.opendaylight.org/show_bu...

https://lists.opendaylight.org/piperm...

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2015-04-03 07:19:32 -0700

Seen: 384 times

Last updated: Jun 13 '16