Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

plugin osgi bundle failed

asked 2015-03-31 09:01:50 -0700

vinllen gravatar image

updated 2015-03-31 09:23:49 -0700

Hi, Dear all:

I write a sample plugin "ping", and then i want insert this bundle into my controller. But error occurs when i start it in the OSGI, it show:

gogo: BundleException: The bundle "org.opendaylight.controller.ping.plugin_0.4.0.SNAPSHOT [98]" could not be resolved. Reason: Missing Constraint: Import-Package: org.opendaylight.controller.sal.binding.api; version="[1.1.0,2.0.0)"

Referring from this post page, I understand that I've got a newer version of a plug-in without its dependencies.

The error shows that the minimum version number of org.opendaylight.controller.sal.binding.api is 1.1.0, and mine version is 1.0-1 as i lookup in my directory of controller/opendaylight/distribution/opendaylight/target/distribution.opendaylight-osgipackage/opendaylight/plugins.

My question is how to switch the version from 1.0-1 to 1.1, i can find the 1.1 version of sal.binding.api in my directory: ~/.m2/repository/org/opendaylight/controller/sal-binding-api/1.1-SNAPSHOT.

As i look into my pom.xml, i foud my dependency is 1.1:

<dependency>
      <groupId>org.opendaylight.controller</groupId>
      <artifactId>sal-binding-api</artifactId>
      <version>1.1-SNAPSHOT</version>
    </dependency>

I think it's very strange.

Great appreciation for anyone's reply!

Best Regards, Vinllen

edit retag flag offensive close merge delete

Comments

As i look into my pom.xml, i foud my dependency is 1.1: <dependency> <groupid>org.opendaylight.controller</groupid> <artifactid>sal-binding-api</artifactid> <version>1.1-SNAPSHOT</version> </dependency> I think it's very strange

vinllen ( 2015-03-31 09:22:45 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-04-01 02:29:04 -0700

vinllen gravatar image

I have solved this problem: change the version 1.1 to 1.0-1 in pom.xml. After then , if have any other problems, change the version 1.1 to 1.0-1 with the different jar packet continue.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-03-31 09:01:50 -0700

Seen: 122 times

Last updated: Apr 01 '15