Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode


Controller monitoring through RMI

asked 2015-03-14 13:21:46 -0700

anonymous user


updated 2015-03-14 23:19:34 -0700

I am running distribution-karaf-0.2.1-Helium-SR1.1. I do a ./karaf and start the controller it's starts up on localhost. However I want it to start on a specific IP. How do i do that?

I am trying to give it an IP so that I can have jconsole running on a machine and can connect to the controller for remote management.

Any help is appreciated.


Update: This works now with the local IP. But I am unable to configure jconsole to talk to Opendaylight on port 1099.

Update 2: Here is the output of from the commands. which show that 1099 is tied to 5733 java process of the open daylight. netstat -an | grep 5005 shows nothing listening for me to establish connection with.

netstat -an | grep 1099 tcp6 0 0 :::1099 :::* LISTEN

netstat -tunlp | grep 1099 tcp6 0 0 :::1099 :::* LISTEN 5733/java

ps -eaf | grep 5733 root 5733 5732 99 00:12 pts/1 00:04:32 /usr/bin/java -server <some-options> OpenDayLight/distribution-karaf-0.2.1-Helium-SR1.1/lib/karaf.jar org.apache.karaf.main.Main</some-options>

edit retag flag offensive close merge delete


Isn't Jconsole works on port 5005 by default ? Plz check it.

faizan ( 2015-03-14 21:40:04 -0700 )edit

Seems like some config Issue: Try this, In /controller/karaf/opendaylight-karaf/target/assembly/etc/ Go to and change to your machine IP like x.x.x.x :) and run karaf and try to connect.

faizan ( 2015-03-14 23:39:41 -0700 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-03-14 19:36:00 -0700

faizan gravatar image

Isn't IP of your local machice works too for remote management ? Your machine must have some ip.

edit flag offensive delete publish link more
Login/Signup to Answer


Asked: 2015-03-14 13:21:46 -0700

Seen: 150 times

Last updated: Mar 14 '15