Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

Opendaylight Helium SR2 with Openstack Juno

asked 2015-03-14 08:24:18 -0800

krishna_kashyap gravatar image

On reboot, flows are not restored on the OVS. Also on trying to access networks, ports and subnets on the ODL, they return empty lists. Any idea what could be causing this?

edit retag flag offensive close merge delete

Comments

Could you clarify what you mean by reboot? I'm assuming OVS reboot, just to be sure. How're you trying to access networks, ports and subnets on ODL?

Vishal Thapar ( 2015-03-15 23:12:37 -0800 )edit

I tried a system reboot, which also rebooted the ODL. Using curl on http://<controllerip>:8080/controller/nb/v2/neutron/networks. Port and subnets were also accessed similarly

krishna_kashyap ( 2015-03-15 23:16:38 -0800 )edit

Yeah, just figured that out. That's kind of tricking the ODL mechanism driver to syncing, which seem to work. Guess a better way to sync in initialization would be a better solution though

krishna_kashyap ( 2015-03-16 05:58:05 -0800 )edit

That is where persistence comes in. If ODL persisted the data, no need to sync on restart. Only sync required will be for any changes made while ODL was unavailable.

Vishal Thapar ( 2015-03-16 06:51:47 -0800 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-15 23:57:20 -0800

Vishal Thapar gravatar image

Is OpenStack also running on same node? Try creating a new network or port from Neutron. I don't think ODL persists data unless running in clustered mode. https://wiki.opendaylight.org/view/Running_and_testing_an_OpenDaylight_Cluster#Single_Instance_with_Clustering

edit flag offensive delete publish link more
Login/Signup to Answer

Stats

Asked: 2015-03-14 08:24:18 -0800

Seen: 54 times

Last updated: Mar 14 '15