Ask Your Question
0

Trying to integrate the OpenStack Juno with Helium release of Opendaylight getting the error

asked 2015-03-10 05:33:42 -0700

prdmandava gravatar image

I followed the link for the integartion https://wiki.opendaylight.org/view/OpenStackandOpenDaylight. Every thing went well. When checking for the curl call getting the error. Don't get confuse the. I used the 8181 port in the config file of the ml2_conf.ini for the url.

"curl -u admin:admin http://192.168.15.193:8181/controller/nb/v2/neutron/networks"

OUTPUT for the call

<meta content="text/html;charset=utf-8" http-equiv="Content-Type"/> <title>Error 404 Not Found</title>

HTTP ERROR: 404

Problem accessing /controller/nb/v2/neutron/networks. Reason:

    Not Found


Powered by Jetty://

Karaf.log

Mar 10, 2015 4:27:42 AM org.apache.karaf.main.lock.SimpleFileLock lock INFO: Trying to lock /opt/stack/opendaylight/distribution-karaf-0.2.2-Helium-SR2/lock Mar 10, 2015 4:27:42 AM org.apache.karaf.main.lock.SimpleFileLock lock INFO: Lock acquired Mar 10, 2015 4:27:42 AM org.apache.karaf.main.Main$KarafLockCallback lockAquired INFO: Lock acquired. Setting startlevel to 100 2015-03-10 04:27:44,671 | INFO | Event Dispatcher | FeaturesServiceImpl | 24 - org.apache.karaf.features.core - 3.0.1 | Installing feature region 3.0.1 2015-03-10 04:29:03,558 | WARN | Event Dispatcher | AetherBasedResolver | 5 - org.ops4j.pax.url.mvn - 1.6.0 | Error resolving artifactorg.eclipse.equinox:region:jar:1.0.0.v20110506:Could not transfer artifact org.eclipse.equinox:region:jar:1.0.0.v20110506 from/to central ( http://repo1.maven.org/maven2/ ): Error transferring file: Connection refused org.sonatype.aether.resolution.ArtifactResolutionException: Could not transfer artifact org.eclipse.equinox:region:jar:1.0.0.v20110506 from/to central ( http://repo1.maven.org/maven2/ ): Error transferring file: Connection refused at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:538) at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:216) at org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:193) at org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:286) at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:250) at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolveFile(AetherBasedResolver.java:239) at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:223) at org.ops4j.pax.url.mvn.internal.Connection.getInputStream(Connection.java:122) at java.net.URL.openStream(URL.java:1037)[:1.7.0 75] at org.apache.karaf.features.internal.BundleManager.getInputStreamForBundle(BundleManager.java:173) at org.apache.karaf.features.internal.BundleManager.doInstallBundleIfNeeded(BundleManager.java:92) at org.apache.karaf.features.internal.BundleManager.installBundleIfNeeded(BundleManager.java:86) at org.apache.karaf.features.internal.FeaturesServiceImpl.doInstallFeature(FeaturesServiceImpl.java:529) at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:393) at org.apache.karaf.features.internal.BootFeaturesInstaller.installBootFeatures(BootFeaturesInstaller.java:92) at org.apache.karaf.features.internal.BootFeaturesInstaller.start(BootFeaturesInstaller.java:76) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.7.075] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)[:1.7.075] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[:1.7.075] at java.lang.reflect.Method.invoke(Method.java:606)[:1.7 ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-09-16 08:46:27 -0700

90.suman gravatar image

AFAIK, neutron interacts with ODL on port 8080 and not 8181.

Change the ml2 config file and restart neutron -server,if everything else is fine you will get a response with empty networks.

edit flag offensive delete publish link more

Comments

Yep, that uri is for NN and default port for it is 8080, not 8181.

Vishal Thapar ( 2015-09-22 04:22:35 -0700 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-03-10 05:33:42 -0700

Seen: 302 times

Last updated: Sep 16 '15