Ask Your Question
0

ODL DLUX can't see hosts only switch is seen

asked 2015-03-04 06:12:29 -0700

anonymous user

Anonymous

updated 2015-03-04 06:27:42 -0700

I started mininet with

 sudo mn --topo single,3 --mac --controller remote,ip=.... port=6653 --switch ovsk,protocols=OpenFlow13

Then I started ODL(Helium Karaf)which is at another PC. I installed "odl-openflowplugin-all", "odl-dlux-core" "odl-restconf" "odl-mdsal-apidocs" "odl-openflowplugin-flow-services-ui" "odl-openflowplugin-flow-services-rest".

Then from the pc which is mininet is running I add manually a flow to the switch between h1 and h2.

   sudo ovs-ofctl -O OpenFlow13 add-flow "s1" in_port=2,actions=output:1

   sudo ovs-ofctl -O OpenFlow13 add-flow "s1" in_port=1,actions=output:2

Then from the mininet I use "pingall" command. h1 and h2 can ping but couldn't see h3 which is expected.

Finally I tried to check from the dlux the topology and flow. I couldn't see hosts and flow. I don't know the reason.

Thanks in advance,

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-03-04 13:33:45 -0700

Nuno gravatar image

updated 2015-03-04 16:15:23 -0700

You need odl-l2switch-switch that includes hosttracker which is the module responsible for knowing when hosts are. You will only see the hosts in the northbound API when they exchange Arp packets. You might try to ping and even if the ping isn't successful the hosttracker will "locate" the hosts because the switch is connected to the controller.

[EDIT]

You want the network to not have connectivity until you install flows in order to do it. Since you are using karaf go to the folder etc/opendaylight/karaf and there you have the configuration files for l2switch and others. You can see here ( https://wiki.opendaylight.org/view/L2Switch:Helium:UserGuide) what flags are use and its purpose. If you don't want the network to ping at start set the flag "is-proactive-flood-mode" from file "54-arphandler.xml" to false and flag "is-learning-only-mode" from file "58-l2switchmain.xml" to true. This way you have l2switch and other modules without installing the flows that "create" connectivity in your network.

[EDIT]

Regards, Nuno B.

edit flag offensive delete publish link more

Comments

Thanks Nuno, your suggestions worked perfectly

berkay ( 2015-03-05 01:58:35 -0700 )edit

Glad to help =)

Nuno ( 2015-03-05 03:50:41 -0700 )edit

I had the same issue , now it works perfectly . . . I am able to see hosts on the DLUX UI . Thanks !!

joshua.jeyaraj ( 2015-08-13 20:03:48 -0700 )edit
0

answered 2015-03-04 13:52:55 -0700

berkay gravatar image

first of all thanks for inside about l2switch. However, my main purpose with not loading this module is to disable the automatic ping flow. I will try your suggestion but what I am looking for is until I installed the flow manually either directly at switch or by rest api, I want hosts are not to eable to ping each other.

Regards, Berkay

edit flag offensive delete publish link more

Comments

You can try just install the host tracker feature of the L2switch, but for it to be useful as Nuno pointed out is the controller needs to see the ARP packets so it know switch and port it came from, based on the packet_in message.

Chris O'Shea ( 2015-03-04 14:08:19 -0700 )edit

Check the [EDIT] section on my answer. It was too big to be on the comment. I think that's what you are looking for.

Nuno ( 2015-03-04 16:12:52 -0700 )edit

i was able to see the host before but once my system got rebooted,from that time i couldnt able to see the host but only switches. and i dont have opendaylight in etc folder. thank you.

shaik sadulla ( 2016-02-29 03:07:19 -0700 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-03-04 06:12:29 -0700

Seen: 2,854 times

Last updated: Mar 04 '15