Ask is moving to Stack Overflow and Serverfault.com! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode

0

After integrating openstack with ODL, VMs donot get IP

asked 2015-02-24 01:02:16 -0800

Janki gravatar image

Hi

I have 3 node architecture OpenStack setup running successfully. I can see IPs allocated to VMs in horizon and by ifconfig command in the VMs console.

I then integrated this with OpenDayLight and the integration is successful. I can see IPs assigned to VMs in the Horizon.

But ifconfig command in the VMs console doesnot show IP.

dnsmasq is running. DHCP namespaces are getting created and attaching to VM.

Yet IP is not allocated. What could be the reason and how to solve this?

edit retag flag offensive close merge delete

Comments

I have the same problem. I also used ip netns <name space=""> tcpdump -i tap-XXX -e -n and it shows no packets. When you create the network, sub-network and router with you horizon do you also see namespace of the router when you run command ip netns (Like this: qdhcp-* qrouter-*)?

sunday ( 2015-02-24 10:50:57 -0800 )edit

Hello, I apologize if this is not the proper format to ask for help (first time posting) but I was wondering if you could share the resources you used to successfully integrate ODL with Openstack. I'm specifically looking for Helium-Juno. I would prefer not to use Devstack as I already have Juno up.

Kiru ( 2015-03-04 21:01:50 -0800 )edit

I dont know about Juno. I have Icehouse installed. Follow this wiki https://wiki.opendaylight.org/view/OpenStack_and_OpenDaylight. Launch an instance and check if it is allocated an IP. If you are using GRE tunnel, check if the tunnel is created and if not run these 2 commands on compute and neutron node. Run ovs-vsctl get Open_vSwitch . _uuid It will return a uuid, lets call it uuid_returned. Run ovs-vsctl set Open_vSwitch <uuid_returned> other_config:local_ip=<ip-of-your-data-interface> Data interface here refers to whichever interface you want data traffic to use.

Janki ( 2015-03-04 23:15:45 -0800 )edit

Thanks a lot, Janki. I was finally able to technically integrate ODL with Openstack (I get "is true" when checking ovs-vsctl show command) but I'm running in other issues that is preventing me from launching a VM properly (probably not related to the integration) to check if the networks are being created properly.

Kiru ( 2015-03-06 13:16:54 -0800 )edit

What problems are you facing?

Janki ( 2015-03-10 21:43:43 -0800 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-26 03:36:54 -0800

Vishal Thapar gravatar image

Resolved the issue in IRC but documenting here for others who run into the same. The key problem here was that Janki was using GRE as tenant network type.

To support GRE one additional step is needed that is missing in the wiki. On controller and each compute node, after setting the manager local_ip needs to be configured as follows:

  1. Run ovs-vsctl get Open_vSwitch . _uuid It will return a uuid, lets call it uuid_returned.
  2. Run ovs-vsctl set Open_vSwitch <uuid_returned> other_config:local_ip=<ip-of-your-data-interface> Data interface here refers to whichever interface you want data traffic to use.
edit flag offensive delete publish link more
0

answered 2015-02-25 11:25:26 -0800

sunday gravatar image

updated 2015-02-25 11:29:03 -0800

First check you have all the bridges on the OVS switch (br-int,br-ex,br-tun)

Now you have to troubleshot step by step:

  1. First see it you have any OpenFlow-s on you br interfaces (br-int, br-ex, br-tun)

ovs-ofctl -O Openflow13 dump-flows br-int

ovs-ofctl -O Openflow13 dump-flows br-ex

ovs-ofctl -O Openflow13 dump-flows br-tun

they mustard be empty. If they are empty this is a problem.

  1. Execute neutron agent-list and check if DHCP agents and L3 agents have a the value of True in the column adminstateup.
  2. Execute ovs-vsctl show and check if every OVS bridge has the two lines:

        Controller "tcp:<ODL_IP>:6633"
        is_connected: true
    
edit flag offensive delete publish link more

Comments

Initially there was only br-int on both neutron and compute node. So I manually added br-tun on compute node and br-tun and br-ex on neutron. There are no flows on br-tun on both compute and neutron nodes. 1. DHCP, l3 and metadata agents are up and runnning. 2. All bridges are connected to controller and can be seen in dlux.

Janki ( 2015-02-26 01:52:22 -0800 )edit

I don't think you need br-tun with Helium. What are the flows on br-int? when sharing the output please do point out what each of those output port means [output of `ovs-dpctl show`]

Vishal Thapar ( 2015-02-26 02:11:51 -0800 )edit

on neutron: ovs-ofctl -O OpenFlow13 dump-flows br-int OFPST_FLOW reply (OF1.3) (xid=0x2): cookie=0x0, duration=3752.202s, table=0, n_packets=671, n_bytes=59719, send_flow_rem dl_type=0x88cc actions=CONTROLLER:65535 cookie=0x0, duration=3752.202s, table=0, n_packets=0, n_bytes=0, send_flow_rem priority=0 actions=goto_table:20 cookie=0x0, duration=3752.202s, table=20, n_packets=0, n_bytes=0, send_flow_rem priority=0 actions=goto_table:30 cookie=0x0, duration=3752.202s, table=30, n_packets=0, n_bytes=0, send_flow_rem priority=0 actions=goto_table:40 cookie=0x0, duration=3752.202s, table=40, n_packets=0, n_bytes=0, send_flow_rem priority=0 actions=goto_table:50 cookie=0x0, duration=3752.202s, table=50, n_packets=0, n_bytes=0, send_flow_rem priority=0 actions=goto_table:60 cookie=0x0, duration=3752.202s, table=60, n_packets=0, n_bytes=0, send_flow_rem priority=0 actions=goto_table:70 cookie=0x0, duration=3752.202s, table=70, n_packets=0, n_bytes=0, send_flow_rem priority=0 actions=

Janki ( 2015-02-26 02:22:49 -0800 )edit

on neutron: ovs-ofctl -O OpenFlow13 dump-flows br-ex OFPST_FLOW reply (OF1.3) (xid=0x2): cookie=0x0, duration=2080.778s, table=0, n_packets=0, n_bytes=0, send_flow_rem dl_type=0x88cc actions=CONTROLLER:65535 cookie=0x0, duration=2080.273s, table=0, n_packets=121809, n_bytes=10775628, send_flow_rem priority=0 actions=NORMAL

Janki ( 2015-02-26 02:24:22 -0800 )edit

neutroneinfochipscom@neutron:~$ sudo ovs-dpctl show system@ovs-system: lookups: hit:3345679 missed:1350665 lost:7274 flows: 137 port 0: ovs-system (internal) port 1: br-int (internal) port 2: br-tun (internal) port 3: gre_system (gre: df_default=false, ttl=0) port 4: br-ex (internal) port 5: eth8

Janki ( 2015-02-26 02:25:03 -0800 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2015-02-24 01:02:16 -0800

Seen: 2,012 times

Last updated: Feb 26 '15