Ask is moving to Stack Overflow and! Please use the "opendaylight" tag on either of these sites. This site is now in Read-Only mode



asked 2015-02-17 23:32:40 -0700

SAMARTH gravatar image

I have added proper public key to ssh public keys on ODL website. Stil i am getting permission denied when i tried connecting to odl using ssh.

edit retag flag offensive close merge delete


I have the same problem, the key doesn't seem to be deployed. In the dashboard, the status of the key is empty, is this normal?

wouterdb ( 2016-06-10 03:55:27 -0700 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2015-02-18 02:37:13 -0700

Divya gravatar image

You generate the key using ssh-keygen in terminal. Now copy the key from .ssh/ file and sign in to opendaylight :,n,z Go to settings ->SSH public keys->Add key. Paste key and add it. If you have followed the above procedure then it should work.

edit flag offensive delete publish link more


Hi, Thanks for you response. I followed the same procedure. Still it shows Permission denied(public key) error when i try connecting to the git website to clone.. Do we have to modify something after adding the key?? my key looks like this: ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDC4do2cjuEPoe9JbIEGWqfXLjHax7rgbkX3UwUnzHoRifm5SeQr08SwIf+7thu8KKlcoHy3X8A2Pdjc0WfCEK5S/QDfzfSGk+PMoVJzJNtkhY/WIf7tvrTH9FDa8ej2kS4TYowKmJ3afgVaDB1HiATRcp6p5EcRIW1R7oGjs2JAWvOvvVQDFhFvKd16EP8SD5xkq2S6oJ+ESDv7KbmE3Yg3E6oMwYIELNV29nU/zxaxnBcFE+Y2HhEFboXH3FPtMtosiAWneqtFjq7rYhdUdsy3drhj8aCXIGm9PrhFQ5NNSw289SzAxcUWuUGfcbtAen91SyzMAkax4/ObNAyWcut samarthkn@ubuntu I just copied the whole thing and pasted in that window and said Add Key..

SAMARTH ( 2015-02-21 23:02:34 -0700 )edit

answered 2016-03-16 04:51:33 -0700

aljoby gravatar image

Hi Samarth,

Have you found solution for this problem? if so, please let me know


edit flag offensive delete publish link more
Login/Signup to Answer


Asked: 2015-02-17 23:32:40 -0700

Seen: 506 times

Last updated: Mar 16 '16