Ask Your Question
0

[Opendaylight and Openstack ] No Bridge br-int on compute node

asked 2015-02-12 08:28:34 -0700

apoiget gravatar image

updated 2015-02-12 23:56:32 -0700

Hi,

I try to install Opendaylight with openstack icehouse , I have followed https://wiki.opendaylight.org/view/OpenStackandOpenDaylight. I have one controller node and two compute node

I have a problem in Configuring Open vSwitch to be managed by OpenDaylight When I do ovs-vsctl show on compute node , I got vs-vsctl:

 unix:/usr/local/var/run/openvswitch/db.sock: database connection failed (No such file or directory)

It's "working" with ovs-vsctl --db=$OVS_DB show (with unix:/var/run/openvswitch/db.sock ), but I got only

    Manager "tcp:192.168.1.4:6640"
    is_connected: true
ovs_version: "2.3.1-git3282e51"

In the controller node :

34bb0ded-a716-4566-bb97-f0f2c55cf0e2
Manager "tcp:192.168.1.4:6640"
    is_connected: true
Bridge br-int
    Controller "tcp:192.168.1.4:6633"
        is_connected: true
    fail_mode: secure
    Port "tap9a6feb26-24"
        Interface "tap9a6feb26-24"
            type: internal
    Port "tap2d74b8da-c1"
        Interface "tap2d74b8da-c1"
            type: internal
    Port int-br-private
        Interface int-br-private
    Port br-int
        Interface br-int
            type: internal
Bridge br-private
    Controller "tcp:192.168.1.4:6633"
        is_connected: true
    Port "enp1s0f0"
        Interface "enp1s0f0"
    Port phy-br-private
        Interface phy-br-private
    Port br-private
        Interface br-private
            type: internal
ovs_version: "2.3.1-git3282e51"

I don't have the Bridge br-int like indicated in the documentation

In data/log/karaf.log :

java.lang.IllegalStateException: No LoginService for org.eclipse.jetty.security.authentication.BasicAuthenticator
....
2015-02-12 22:45:06,459 | ERROR | OM-OPER-DCL-8927 | OF13Provider                     | 116 - slf4j.api - 1.7.2 | nable to spot Bridge Identifier for br-int in OVS|192.168.1.2:40998
2015-02-12 22:45:06,459 | ERROR | OM-OPER-DCL-8927 | OF13Provider                     | 116 - slf4j.api - 1.7.2 | Unable to spot Bridge Identifier for br-ex in OVS|192.168.1.2:40998
2015-02-12 22:45:06,459 | ERROR | OM-OPER-DCL-8927 | OF13Provider                     | 116 - slf4j.api - 1.7.2 | Unable to spot Bridge Identifier for br-int in OVS|192.168.1.6:51695
2015-02-12 22:45:06,460 | ERROR | OM-OPER-DCL-8927 | OF13Provider                     | 116 - slf4j.api - 1.7.2 | Unable to spot Bridge Identifier for br-ex in OVS|192.168.1.6:51695
2015-02-12 22:45:06,461 | ERROR | OM-OPER-DCL-8927 | OF13Provider                     | 116 - slf4j.api - 1.7.2 | Unable to spot Bridge Identifier for br-ex in OVS|192.168.1.4:48616
2015-02-12 22:45:10,232 | WARN  | OM-OPER-DCL-8927 | OF13Provider                     | 116 - slf4j.api - 1.7.2 | Tunnel end-point configuration missing. Please configure it in OpenVSwitch Table. Check source null or destination null
2015-02-12 22:45:10,233 | WARN  | OM-OPER-DCL-8927 | OF13Provider                     | 116 - slf4j.api - 1.7.2 | Tunnel end-point configuration missing. Please configure it in OpenVSwitch Table. Check source null or destination null
edit retag flag offensive close merge delete

Comments

ovs-vsctl show by itself should've worked fine, check your OVS installation. You need to provide some more information. How're you installing OpenStack, devstack? If devstack, your local.conf? Was it a fresh setup or changed non-ODL OpenStack to use ODL?

Vishal Thapar ( 2015-02-12 21:53:37 -0700 )edit

No, br-int should also be on the compute node. I am not familiar enough with packstack to answer how to configure packstack for ODL. On your compute node try to delete manager 'ovs-svctl del-manager' and set it again. br-int is created by ODL when OVS connects to it over 6640.

Vishal Thapar ( 2015-02-13 00:22:56 -0700 )edit

I have try this, but nothing change I have a question about security group, are they mandatory ? When I try to disable commenting security_group_api in nova.conf and putting false to enable_security_group in ml2_conf.ini. I got the error "Enable to retrieve list of security groups"

apoiget ( 2015-02-13 01:19:31 -0700 )edit

HI Apoiget, Could you get to figure out the root cause of this. Thanks Badri

Badrinath ( 2015-07-09 02:41:56 -0700 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-12 23:33:09 -0700

apoiget gravatar image

br-int is only on the controller node ? I use packstack to install Openstack, I checked Openstack was working (creating network, spawning VM) then I install ODL

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-02-12 08:28:34 -0700

Seen: 1,238 times

Last updated: Feb 12 '15