Ask Your Question
0

add flow by gui ?- helium

asked 2015-01-21 03:00:28 -0700

buddah gravatar image

HI there , sorry to bother, anyone having problems adding flows by gui? is that my switch appears in topology, but when i want to add flows , i can't because i cant select the node, nothing there...

Thanks.

edit retag flag offensive close merge delete

Comments

I have had a theory, but haven't had the time to test. what is your switch ID? (i believe it may only be an issue when using a switch with an large Id number)

Chris O'Shea ( 2015-02-20 10:06:32 -0700 )edit

I'm not sure, but it may be related to this bug: https://bugs.opendaylight.org/show_bug.cgi?id=2190

tbachman ( 2015-02-22 05:21:49 -0700 )edit

Chris 0'Shea... well it has a large id number (ten or more ), can i put it smaller? thanks

buddah ( 2015-02-23 01:11:46 -0700 )edit

I seen it work with small numbers IE Openflow:1, openflow:2, openflow:3 but also hear lot of issues with this part,

Chris O'Shea ( 2015-02-23 14:05:43 -0700 )edit

even me facing the same issue,while trying to create flow from UI, its not displaying anything in node m trying with openflow:1.

heena ( 2015-03-17 04:44:13 -0700 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-20 08:31:52 -0700

Luca gravatar image

Yeah, I have the same problem, from the dlux page when I try to create a flow I can't because there are no nodes to select. I did not find a solution yet.

edit flag offensive delete publish link more

Comments

I'm also facing the same issue, but i have deployed AD-SAL application on helium controller. Able to see topology on GUI but could not install/add flows.

praneethmadhav ( 2015-03-15 09:03:49 -0700 )edit

Yes, I have also the same problem. Maybe the only solution is to add flow through the Rest API.

ralvarep ( 2015-03-31 13:16:21 -0700 )edit
0

answered 2015-03-14 16:55:37 -0700

pm.preetam gravatar image

Hey! Did you guys figure out the way to add the flows? I have asked a similar question here.

Any inputs will be greatly appreciated :) Thanks

edit flag offensive delete publish link more

Comments

Can you see if it has a large number for the openflow ID and see if the Bug ID 2190 has been fixed and patched?

Chris O'Shea ( 2015-03-14 18:44:03 -0700 )edit

In the topology I see the openflow switch ID as openflow:1 and in connection manager the same is shown as 00:00:00:00:00:00:00:01

pm.preetam ( 2015-03-14 20:32:30 -0700 )edit

Hi Chris, I am not sure how to check if the Bug ID 2190 has been fixed. From my previous comment does that look like its fixed?

pm.preetam ( 2015-03-16 02:15:15 -0700 )edit

even I see the openflow switch ID as openflow:1 but m not able to see anything in connection manager.

heena ( 2015-03-17 04:48:10 -0700 )edit

Same problem here. I am able to see the switches in connection manager but unable to add flows through the flowprogrammer tab.

checho ( 2015-03-25 13:36:03 -0700 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
5 followers

Stats

Asked: 2015-01-21 03:00:28 -0700

Seen: 419 times

Last updated: Mar 14 '15