Ask Your Question
0

Where can i disable the reactive feature of ODL controller ?

asked 2014-12-08 04:53:36 -0700

Nuno gravatar image

So I've downloaded opendaylight controller from gerrit (git clone ssh://<username>@git.opendaylight.org:29418/controller.git). However when i connect it to the mininet, it installs flows reactively. When i go to the webinterface (localhost:8080) it does not have any "default" flow so i'm guessing that the packets are sent to the controller, and he creates flows according to it, allowing traffic. What i want to know is what module is doing that in order to modify it according to my needs? Thanks in advance</username>

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-29 21:50:58 -0700

yogesh_pandey gravatar image

updated 2014-12-29 21:52:17 -0700

Opendaylight by default comes with a module that installs flows depending on the topology that it reads during runtime. You can disable this feature by stopping the simpleforwarding osgi bundle.

  1. Goto the terminal in which ODL is running.
  2. Write ss simple.
  3. You will get and id with which the bundle is running.
  4. Stop that id using "stop 67".In my case the id is 67.

now the flows will not be installed by default.

edit flag offensive delete publish link more

Comments

I'm using HeliumSR2 that does not come with the l2forwarding module. Helium uses L2switch which has a configuration file that causes the controller not to install those flows reactively. However that flag is not working, not sure why.

Nuno ( 2015-02-23 06:49:24 -0700 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2014-12-08 04:53:36 -0700

Seen: 479 times

Last updated: Dec 29 '14