Mitaka Beryllium Integration Problem 9696 connection problem

asked 2017-04-13 21:29:11 -0700

gossettf gravatar image

updated 2017-04-17 09:20:11 -0700

I've installed Mitaka per the installation guide -even partially integrated ODL where ODL can see the OpenStack vswitches (but can't create any network objects -for the same reason "Unable to establish to connection to http://controller:9696..." ) ...Any help or ideas on this problem would be most appreciated.

Trying many of the neutron router-create, ext-list and others ...I constantly get connection errors like...

gossettf@controller:~$ neutron ext-list Unable to establish connection to http://controller:9696/v2.0/extension.. . gossettf@controller:~$ neutron router-create router1 Unable to establish connection to http://controller:9696/v2.0/routers.json etc...

In fact I can't even find a subdirectory on the machine referencing "v2.0" ...and the only reference I see on the controller to extensions.json is off my home directory i.e.

gossettf@controller:~$ sudo find / -name extensions.json -print /home/gossettf/.mozilla/firefox/txqc9jay.default/extensions.json

...and I do not see a process listening on 9696 -even though I have references to them in the .conf files per the mitaka installation references.

I have looked everywhere for possible problem sources -even uncommented the "bind_port = 9696" parameter in neutron.conf, rebuilt the data base, stopped/restarted the services ... and nothing seems to work. I cannot get a connection to port 9696 on the controller.

e.g.

gossettf@controller:~$ sudo /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf \

--config-file /etc/neutron/plugins/ml2/ml2conf.ini upgrade head" neutron [sudo] password for gossettf: No handlers could be found for logger "osloconfig.cfg" INFO [alembic.runtime.migration] Context impl MySQLImpl. INFO [alembic.runtime.migration] Will assume non-transactional DDL. Running upgrade for neutron ... INFO [alembic.runtime.migration] Context impl MySQLImpl. INFO [alembic.runtime.migration] Will assume non-transactional DDL. OK INFO [alembic.runtime.migration] Context impl MySQLImpl. INFO [alembic.runtime.migration] Will assume non-transactional DDL. Running upgrade for neutron-fwaas ... INFO [alembic.runtime.migration] Context impl MySQLImpl. INFO [alembic.runtime.migration] Will assume non-transactional DDL. OK

gossettf@controller:~$ sudo service nova-api restart nova-api stop/waiting nova-api start/running, process 18880 gossettf@controller:~$ sudo service neutron-server restart neutron-server stop/waiting neutron-server start/running, process 19430 gossettf@controller:~$ sudo service neutron-linuxbridge-agent restart neutron-linuxbridge-agent stop/waiting neutron-linuxbridge-agent start/running, process 19705 gossettf@controller:~$ sudo service neutron-dhcp-agent restart neutron-dhcp-agent stop/waiting neutron-dhcp-agent start/running, process 20124 gossettf@controller:~$ sudo service neutron-metadata-agent restart neutron-metadata-agent stop/waiting neutron-metadata-agent start/running, process 20365 gossettf@controller:~$ sudo service neutron-l3-agent restart neutron-l3-agent stop/waiting neutron-l3-agent start/running, process 20631

gossettf@controller:~$ neutron ext-list Unable to establish connection to http://controller:9696/v2.0/extension.. .

gossettf@controller:~$ sudo find / -name extensions.json -print /home/gossettf/.mozilla/firefox/txqc9jay.default/extensions.json gossettf@controller:~ $ sudo find / -name v2.0 -print

gossettf@controller:~$ netstat -a | grep 9696 <no output....><="" p="">

...Many thanks if you got this far reading this problem's details.

Problem details follow...

Unfortunately ...no solution after multiple rebuilds of Mitaka and even selfservice, provider networks successfully provisioned with Horizon/dashboard working. It seems that around the time I "Reset Neutron's ... (more)

edit retag flag offensive close merge delete

Comments

Seems like Mitaka/OpenStack quit listening on tcp/9696 after rebuilding the ml2 database i.e. "drop database if exists neutron_ml2;"; mysql -e "create database neutron_ml2 character set utf8;"; mysql -e "grant all on neutron_ml2.* to 'neutron'@'%';"; ...Wonder what that problem could be?

gossettf ( 2017-04-16 23:44:00 -0700 )edit