Karaf - "checkJvmVersion()"...

asked 2017-04-06 13:31:02 -0800

almjr gravatar image

Hi all... When i try to run the karaf scrip, I get the following errors:

XX@XX:~/Desktop/ODLBoron$ ./bin/karaf ./bin/karaf: line 252: [: : integer expression expected ./bin/karaf: line 297: [: : integer expression expected -Djava.endorsed.dirs=/usr/lib/jvm/java-9-openjdk-amd64/jre/lib/endorsed:/usr/lib/jvm/java-9-openjdk-amd64/lib/endorsed:/home/XX/Desktop/ODLBoron/lib/endorsed is not supported. Endorsed standards and standalone APIs in modular form will be supported via the concept of upgradeable modules. Error: Could not create the Java Virtual Machine. Error: A fatal exception has occurred. Program will exit.

My java home is in place: XX@XX:~/Desktop/ODLBoron$ cd $JAVA_HOME XX@XX:/usr/lib/jvm/java-9-openjdk-amd64$

And java version works too... XX@aXX:/home$java -version openjdk version "9-internal" OpenJDK Runtime Environment (build 9-internal+0-2016-04-14-195246.buildd.src) OpenJDK 64-Bit Server VM (build 9-internal+0-2016-04-14-195246.buildd.src, mixed mode)

What i forgot to setup? Please, some light... Thanks... = = =

edit retag flag offensive close merge delete