Opendaylight on aarch64

asked 2017-03-24 04:01:46 -0700

srik1782 gravatar image

Hi, I am trying to run Opendaylight on aarch64 machine. For that, I followed the following steps:

> git clone https://git.opendaylight.org/gerrit/i...

> cd distribution

> mvn clean install -DskipTests

The build was successful. And I am able to start karaf. But, when I am trying to install the feature ‘odl-dlux-core’, I am getting the following error:

opendaylight-user@root>feature:install odl-dlux-all Refreshing bundles com.sun.jersey.servlet (448), io.netty.codec (377), org.eclipse.persistence.moxy (373), org.opendaylight.controller.config-persister-impl (368), org.jboss.netty (423) Error executing command: Can't install feature odl-dlux-all/0.0.0: Could not start bundle mvn:org.fusesource.leveldbjni/leveldbjni-all/1.8-odl in feature(s) odl-akka-leveldb-0.7: The bundle "org.fusesource.leveldbjni.leveldbjni-all_1.8.0 [418]" could not be resolved. Reason: No match found for native code: META-INF/native/windows32/leveldbjni.dll; processor=x86; osname=Win32, META-INF/native/windows64/leveldbjni.dll; processor=x86-64; osname=Win32, META-INF/native/osx/libleveldbjni.jnilib; processor=x86; osname=macosx, META-INF/native/osx/libleveldbjni.jnilib; processor=x86-64; osname=macosx, META-INF/native/linux32/libleveldbjni.so; processor=x86; osname=Linux, META-INF/native/linux64/libleveldbjni.so; processor=x86-64; osname=Linux, META-INF/native/sunos64/amd64/libleveldbjni.so; processor=x86-64; osname=SunOS, META-INF/native/sunos64/sparcv9/libleveldbjni.so; processor=sparcv9; osname=SunOS opendaylight-user@root>

Can anyone give me a clue, what went wrong. Thanks.

Regards, Srikanth.

edit retag flag offensive close merge delete